cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 right controller paired and connected but not working

KirisuteG
Level 2

The left controller works perfectly but the right one is paired and "connected" but it won't show up on screen and nothing works except for the Oculus button, it doesn't work if i press it but if I hold it the headset will detect it and reset the view, sometimes it's after 2 seconds and up to 5 seconds after I hold it, nothing else in the controller works. 

 

I left the headset turned off and controller without battery overnight, after i turned both on in the morning the controller connected and it worked perfectly for about 5 seconds and stopped working again, same happened after i performed the factory reset 10 minutes after this, the controller connected and worked perfectly for about 5 seconds and started acting up again with the same issues. 

The message "right controller not connected" keeps popping up but sometimes it only shows up for half a second and immediately disappears. 

  

This is a video of the controller's light, it keeps blinking at erratic times, sometimes it barely flashes: 

 

I already tried: 

  • Replacing the batteries  
  • Unpairing and re-pairing to the headset 
  • Leaving the controller without energy overnight 
  • Turning off and on the headset 
  • Looking for a software update (no updates available) 
  • Performing a factory reset. 
2 REPLIES 2

OculusSupport
Community Manager
Community Manager

We appreciate you attempting to troubleshoot prior to reaching out for help with your controller, as well for the detailed description of your doing thus far. Please, feel free to submit a support tickets so one of our lovely agents can get you closer to a possible solution. https://metaque.st/Support

Xyflux.E
Level 2

Did you find a fix? Because I'm having the same issue