cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 updated - froze - reset - now will not pair

Expediter
Level 5
I need some help.

put my quest 2 on this morning and it started installing an update. it froze installing the update and I saw the android logo on his back with a caution sign in the headset. I tried to restart it and it would not. I held the power button down till I could factory reset it. after the factory reset I cant get the headset passed the pairing screen. My phone app shows the device and it pairs. i go in the headset and it will not leave the pairing screen.

I tried downloading the app again and doing a few more factory resets but nothing works. I am stuck int he pairing section and it will not go passed that.

Any help / ideas ?
3 REPLIES 3

Expediter
Level 5
the controllers were not pairing and that's why it would not move ahead. I paired the controllers in the app then reset it one more time and it worked. nothing to see here move on.

hover82
Level 2
Thanks man! I had the exact same problem and had to unpair both controllers with the app and repair and both got new firmware updates while pairing. I would not have solved the issue so fast without you.

k9onthebeat
Level 2
I can’t repair the controllers- need help.