cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 will not connect to WiFi after enabling Link -first time

Jacisse
Level 2

Hello!

 

 I love my Quest 2. I wanted to try some other games on SteamVR. Downloaded the Oculus software, ran Karnage Chronicles, and it was great. However, when I tried to  play a Quest 2 Standalone game, I could not access anything on my device. The error I was given: "Something went wrong." No other info. The internet (CenturyLink) has been somewhat slow today, but it is at 16 mbps for my mother's computer. The last speed test I ran was 1.76 on my pc. Ran a data link test, and CenturyLink reported nothing was wrong. Restarted and reset modem and pc as well as Quest 2. Still unable to play on the Quest 2 without enabling the Oculus Link. 

 

I am trying to download the games already on my Oculus 2 onto the Rift software. Even those downloads fail, and it will not allow any purchases. Not sure what else I can do. Searched this forum.....but found nothing that helps yet.

Thank you and Stay safe!

0 REPLIES 0