cancel
Showing results for 
Search instead for 
Did you mean: 

Quest Right Controller not working

firefist817
Level 3
Basically I just got my quest today and I love it to death but randomly the right controller stopped working. It tracks fine but both triggers dont work, the regular a and b buttons work. I tried changing the batteries which done nothing, restarting the vr, and doing tutorial like 3 times. Something I noticed is when doing the tutorial the animations dont work for you hand on the right at all. Also I realized that the right trigger is constantly down (not physically but in game its always as if its constanyly being pressed down. PLEASE can someone help Im desperate and really want to use this vr.
69 REPLIES 69

GeeseCTM
Level 2
I don't understand.  You guys know that you have to go into the quest app on your phone and pair the controller right?  If it stops working go in and unpair it and then pair it again..

Here's How (and if it works it would be cool if you follow my youtube game channel at GeesePlaysGaimz as a thank you.)

Obviously this won't fix a broken controller but it does work.  If not I messaged support and they issued me a new controller.

To manually pair your Oculus Touch controllers:

  1. Open the Oculus app on your phone.

  2. Tap Oculus Quest 2 or Oculus Quest in the top left corner of your Oculus app.

  3. Tap Settings in the bottom right corner of your app.

  4. Tap Oculus Quest 2 or Oculus Quest under your name and email.

  5. Tap Controllers then tap Left or Right to choose which controller you’d like to pair.

  6. Press and hold the oculus icon and  buttons on your right controller or  and  on your left controller until the controller LED blinks and then lights up to finalize the pairing.

Once you've paired your controllers, the controllers will automatically connect to your headset each time you turn it on, if it's nearby.

To unpair your controllers:

  1. Open the Oculus app on your phone.

  2. Tap Settings from the bottom menu.

  3. Tap the Oculus Quest 2 or Quest headset you currently have paired.

  4. Tap Controller, then tap the controller that you want to unpair.

  5. Tap Unpair Controller.

Did you get it working? That's what happened to mine. So frustrating.

StuJFoster
Level 2

I have the actual solution. This works.

the contacts for the batteries in each controller are the fault.

the fix is very very simple - get tin foil / aluminum foil - fold it into a tiny folded square about 2-3mm thick - find some way of putting it between your + battery and the + terminal - fixed.

if it doesn’t work make the foil square thicker. It will work eventually I promise you.

rashedpr
Level 2

its really not fair this is not from our side it really because of the compony i mean they need to be sued we r losing soooooo much money not just because we bought the vr it self we bought so many games by hundreds of dollars that all cost more than the headset it self common i thought as oculus company that made this vr happens and developed will not give us  broken stuff that it will only work for a few months and then get brooked just to buy more and lose more money i mean i cant accept this result please find a solution for this its not one person who is having such a problem its many people go to the internet YouTube anything watch how many people are having the same thing its not good for your company name even .

Thanks -- worked for mine. I wonder if the contacts drift a little over time.

Happens to me with 2 cv1 and one rift s controller. I also just purchased one because the turnaround is 3-4 weeks in my expierence, but still go through the hoops if under warranty. I have gotten new controllers and headsets from them. Pain in the ass but worth it. 

Bro I need help with my right controller .... who can assist me 

NeverBenBetter
Level 2

Joining the club today. 

For the sake of saving everyone else a lot of time, here is a summary of what is on this thread so far. (I’ve read the seven pages of comments that have been posted to date)

 

  • No one, as of yet, has reported a satisfactory experience with Oculus/Facebook support leading to a resolution
  •  Some people have reported “solutions” but no one has provided a solution that works for everyone. The things people have tried include: (1) trying different batteries, (2) factory reset the oculus (3) take the batteries out of the controller for one minutes, then unpair and pair the controller again. (4) clean out the oculus battery compartment (to wipe it clean of battery fluid spillage) (5) Put a piece of aluminum foil next to the battery contact, (the contract is not tight enough) (6) factory reset the oculus without using the app (power button and volume - button) - I have tried all these and nothing has worked for me.
  •  People who have shelled out more cash for a new controller have had success.
  •  If you are wondering if one of the above solutions will work for you, see if this happens: when you unpair and pair the right controller, do you get a confirmation that “pairing was successful” While nothing seems to happen? The controller continues to blink, as if it was not connected, despite the confirmation message? If this is happening, then you might be in my shoes. I’m at the mercy of Support, otherwise I might be buying another controller.

UPDATE: I reached out to customer service 5/20/21 and they responded within 24 hours. After telling them I had already tried all the recommended solutions, they said they would look into it and, in the meantime, asked for my shipping information. We'll see where this goes...

 

UPDATE 6/9/21 Facebook/Oculus did nothing to help me. They wanted to “investigate the issue further” despite the fact that I referenced this thread. Fortunately, I was able to do an Amazon return and get my money back.

I was in the new batteries/alumnium foil segment but would like to thank you for your service here. Now I know exactly where to go when the right controller malfunctions for reasons other than the ones I can fix with a jury rig.

Agree