cancel
Showing results for 
Search instead for 
Did you mean: 

Quest2 Won't Cast to NVidia Shield

spiceygas
Level 2

Quest 2.  All updates are installed.

Oculus Android App.  All updates are installed.

Nvidia Shield TV Pro.  All updates are installed.

 

All devices are on the same network.

 

When using the VR headset, I can cast to the app but it won't cast to the NVidia Shield TV Pro.  The Shield has a built-in Chromecast.

 

I verified the NVidia Shield is working by casting from a different device.  No problems; works perfectly. 

 

Tried casting directly from the headset (to the Shield device).  It tries for a few seconds and then shows an error.

 

Tried casting to the app, and then having the app redirect to the Shield.  Again, it tries for a few seconds and then shows an error.

 

Given that (a) all devices are fully updates, (b) the NVidia Shield definitely works with casting (tested with other devices), (c) all devices are on the same network, and (d) I've tried with the NVidia shield both wired and wireless...  I suspect something is wrong with the Quest 2.

 

Has anyone else successfully casted from the Quest2 to the NVidia Shield?

2 REPLIES 2

I don't have an answer but I do have exactly the same issue, only it's with 2019 Shield TV (non Pro). 

 

It definitely seems to be an issue with the Quest2. I will try to see if it will cast to Fire tv stick today but I won't be replacing my Shield so still need a fix. 

Ok. Give this a whirl. For "some" reason, I needed to cast any old rubbish from my phone to Shield TV. Then turn it off.

When I now try casting to Shield from either Oculus app or Quest 2 headset it now receives the cast stream. 

 

It's like it needs something else to wake it up. But it's been perfectly fine since