Showing results for 
Search instead for 
Did you mean: 

Random Crashes on TWD:S&S (FIXED)

Level 2

I'm a new Oculus Rift S owner. I built a cheap, new computer just for the Oculus because I didn’t think my old one would run it (I was/am dumb and wrong). But, I also wanted a separate computer for our living room for my family to play the VR. The new computer is a Ryzen 5 2600 (No OC), 16GB 3200 RAM, 750 Watt 80+ Gold, and my old 980 ti (stock) I took out of my old computer. 

My family and I played TWD: S&S for several days with no issues, it ran smoothly on the default graphics settings (we haven’t felt the need to mess with them) but it has randomly started crashing and gives a long error log of TWD_Shipping repeated a few times. I’ve saved all the crashlogs in a desktop folder and tried reinstalling the game twice -- and have even started new game files thinking the saves were corrupted. I’m now up to over 30 crashlogs and I have tried everything I can think of to fix it. 

My BIOs is up to date and I’m running the latest drivers on everything. I’ve gone through and reinstalled all my drivers fresh to see if that helps. I removed Geforce Experience in case that was causing an issue (in-game overlay has always been off). I’ve tried suggestions I’ve found on google but still nothing helps. I’ve even tried beta/non beta in the Oculus settings, the Oculus graphics settings on/off, lowered in-game graphic settings, etc. but the crashes keep coming and the logs don’t help me in figuring out what’s wrong.

Out of curiosity, I installed the game on my old computer (i7-3770k, 16GB RAM, and with an old AMD R9-390). It runs perfectly fine, even with my old motherboard’s USB 3.0 that I thought would be an issue. No crashes, with only a few hiccups of in-game lag. I played passed where I was on the new computer and it didn’t crash a single time. I even tried stressing it with higher settings and nothing bad happened (just not as smooth). I then pulled the 980 ti out of the new computer and stuck it the old computer and… it runs fine. Almost on par with the newer system.

We could just play it on the old computer but the fact that the newer computer won’t run it is driving me up the wall! Especially when every other game runs fine (B&S, Robo Recall, SuperHot, etc.).

I reached out to Oculus support and they said my graphics card isn’t on the recommended list, so that’s probably the problem. They provided a link that stated the game required a 1070 but when I questioned that they then sent me a link that stated that an equivalent card for the 1070 is the… 970? Argh. I didn't brother mentioning that it worked fine on my old computer. They tried to help, but I don't think it's the issue.

At this point any help or direction would be appreciated.


Level 2
Figured it out.

For whatever reason the system wasn't releasing it's Standby memory as we played the game and that's why it was crashing. I checked the memory last night on the Resource Monitor after a crash, we had less than 200 MB free and over 12,000 MB stuck in Standby. Other processes, like Microsoft's YourPhone, was also clogging it up big time.

I found a YouTube video that showed me how to setup a Task Scheduler Action that uses a program (wj32 - Empty Standby List) to clear it automatically every five minutes. We tested it today and played for three hours with no crashes. When I deleted the Action, the crashes returned immediately.

Not sure what's causing it not to free up, but at least this band-aid has stopped the crashes.

Level 3
Thanks for sharing your solution.  A true hero ❤️