cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S display port disconnecting

BobStuntsville
Level 2
when i plug in my rift s, i plug in the usb cable, then wait for it to get detected on the oculus app, then plug in the display port. it connects and everything is good for about a minute, then the led in the headset turns orange and my computer makes a connection noise or something. when i go back to the oculus app on my pc, it says its still connected, then about ten seconds later it updates to say the display port has been disconnected. i tried unplugging and plugging them in again, and resetting the oculus app and resetting my computer but nothing has happened. it was working fine for a month before this. is there any way i can fix it?
5 REPLIES 5

rogue303
Level 2
Does your firmware version also suddenly say 0.0.0 ? This seems to be happening to me as well.

rednekcowboy77
Level 5
uninstall the Oculus software. Then you need to go into Device Manager and uninstall (and check the box to delete the drivers) the superhub usb 3.0 driver, go into appdata and delete anything to do with Oculus. Restart the PC and then redo the setup completely 

rogue303
Level 2
I've done all manner of uninstalling, reinstalling, tried different usb drivers, and it still doesn't work. am communicating with support..

MohWarfighter
Level 3

rogue303 said:

I've done all manner of uninstalling, reinstalling, tried different usb drivers, and it still doesn't work. am communicating with support..


Did you get it to work?

Zaneer
Level 2

i helped my friend with this similar issue. he had a razer game optimiser that "optimised" the steam games, but oculus worked fine. when i disabled it everything worked without problem