cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S losing hand tracking and can't see through passthrough camera

Dapperlad
Level 4
After setting up my Rift S this morning, I played for approximately
2 hours and ran into an issue in Beatsaber where my body movement was
not longer being tracked and I couldn't move my sticks anymore. I went back to the home screen and noticed that my hands were stuck to my side and all I could do was rotate my controllers in place. I was also unable to see anything through the passthrough camera as it was just static.

I've disabled USB 3.0 power management in Windows
I've
tried every USB 3.0 plug on my computer, the ones that do work now only
last for 30 seconds to 3 minutes before static screen comes back and I
lose tracking.
I've unplugged all others USB cables on my computer except keyboard and mouse.
Camera permissions are on for Windows 10
I've reseated the video cable in the headset itself.
Videocard Drivers are up to date
Windows 10 is completely up to date
Rift Firmware is up to date
I've reinstalled Oculus software and run the setup multiple times.

I've seen a few others on Reddit with the same problem. Is this a faulty batch of hardware here?
154 REPLIES 154

Dapperlad
Level 4
New Nvidia driver did not fix current issue. Problem still lies with USB I believe.

Fededale
Level 2


I have a solution. It is a power issue to the headset not getting the required volts from the usb port for long enough.... Get a powered usb hub, plug it into the VR Ready port on the mobo, and then plug into the powered usb hub that way and it has been working very well. It was working almost well without the vr port but it was doing a random reset every 30 seconds that way which was annoying, but the vr port and a usb powered hub works great! so far (knock on wood)


Hi Cyber! Can you confirm that you have solved the problem this way?

cybershrapnel
Level 4
90% yes.....  but not 100%., device still occasionally flickers snow and resets center postiion random. But it did stop the need to reset it and permanent snow thing...

I did however discover an additional trick which is to turn process priority to High or real-time for the 3 oculus exes that are running.... After I did this my device was usable finally.... But I do still see the random snow flicker once in a while, but its much less frequent and it doesn't cause the view to recenter now.... Once again, I believe this to be an issue with the USB cable not providing proper power to the unit or an actual hardware issue.... The need for the additional usb powered hub signifies to me that my hub is providing that little bit of extra power the headset needs to surpass whatever cable/hardware issue is preventing the USB from functioning proper... It is almost certainly a power issue.... Some of it looks fixable via software, ie, it shows some common things to just fix in general in case of hw errors like this, but I do believe these units will need replacing... I am returning mine. The way i have to use it and the way it is hooked up to work is unacceptable. I should not need a powered hub and more than one usb port should work and I should not have to adjust the process priority in task manager.......  This is just really bad imho... I was expecting more for $400... A lot more..... My Go honestly works better 🙂 at least it doesn't shift from 6dof to 3dof and back constantly... Although I have had no further issues with the 3dof switching since doing the priority thing..... And I also tested this on 2 very nice machines..... I know what I am doing. I am a developer and have Comp sci degrees..... All be it not an expert on this specific tech... cmon....

cybershrapnel
Level 4
also I switched from the vr read port to a regular usb 3.0 port, not the vr ready one, it worked better... Like I said, this is just dumb, here are 3 exes to change in task man btw
i1kekcnzh6zt.png

cybershrapnel
Level 4
New NVIDIA Drivers just released TONIGHT!!!!! just now!   Headset is actually working much better with update?? I think.... But I'm tired and am only speaking from a general perception after the update. could be false hope.... But maybe it was the nvidia drivers, but I am still seeing the quick little flashes of static periodically, but not much.... and no recentering. I can't tell if its the drivers or what I did up above now, or both lol.

MAC_MAN86
Level 9
That New Driver 430.86 was out yesterday and already reported as not fixing it.

Knutsi
Level 4
Also, my tracking issues were not fixed by external powered hub, although the issue are somewhat different from this one.

cybershrapnel
Level 4
yah, the issue reoccurred again, but this time I noticed it went away once the oculus room loaded in...

Sinsinful
Level 5

Dapperlad said:

I got the same support e-mail late last evening. I was able to respond quickly and the CSR asked for my production information and purchase receipt from Amazon. Once I sent it they said they'd look into it and "get back to me".



I got the same joke response on my ticket. I have been waiting 3 days now since they said they would get back to me in 48 hours.

cybershrapnel
Level 4
check this bs out
ievyqz5v63q4.png