cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S won't connect - Support won't help

sirlordmrjlw
Level 2

Hello,

 

I was directed to come to the forum pages from the support team after over a month of troubleshooting my Rift S device.  Ever since an update back in February/March my Rift S will no longer connect due to a failed "sensor check".  However, while the sensor check occurs the headset turns on and displays the 3 dot loading screen and will play audio out of the speakers.  

 

I woke up this morning to the latest message from Oculus indicating we have tried all of their troubleshooting and they are no longer able to help me.  My headset is barely over a year old and I now have a ~$450 paperweight.  I have tried everything from reverting the software to a previous version, updating all of my USB port drivers, disabling features that cause issues with supplying power to the USB, sending countless log files, entering the public beta, updating windows, and more.  But at least support "understands how frustrating it is" while they send me off to their forums that I've already searched through for hours.  They have not been able to determine that anything is wrong with the headset from the log files so if anyone out there has a solution I haven't mentioned I would love to hear it.

 

Thanks!

 

2 REPLIES 2

pmneto
Level 3

Have the same issue here.

ive done these steps:

-Reinstall Oculus software 

-Reset Windows from scratch

**My cord is new (changed few months ago)

***I use a powered external USB 3.0 device.

Tried for some times to make a driver rollback and nothing change. Keeps with the same errors:

USB Port Reset Failed/Sensors Can’t track/Three dots eternal loading. 😞

OculusSupport
Community Manager
Community Manager

Hey there!

 

We hate to hear that you are having issues with your Rift S. We understand this is very frustrating and you just want to get back to gaming. Fortunately, we have made some changes to our warranty policy and will now be able to help you sort out these issues. Please reach back out to Oculus Support via a support ticket to get started!