cancel
Showing results for 
Search instead for 
Did you mean: 

[SOLVED]Error During Installation.

TheLastLibraria
Level 2
EDIT: Thanks to LZOLTOWSKI, I ended up looking through the log file and ended up Googling the error line which ended up sending me to another LZOLTOWSKI solved thread where Windows Defender was the culprit. Ended up temporarily disabling it and the installation went through perfectly. Now I'm getting some issue with the headset HDMI and its USB not being recognized, but hopefully I can figure that out. Thanks again LZOLTOWSKI!

My Rift was working perfectly fine before the necessary patch. When I tried to install the patch it kept giving me an error, I ended up uninstalling the Oculus software completely hoping to do a fresh install.

Well, that didn't work at all. I can start the installation process and after it downloads and proceeds to the installation process, it will run for a couple minutes and then it gives me the message: "Restart Computer. Sorry, we encountered an error during installation. Please restart your computer and try running Oculus Setup again."

I tried that several times using several options: unplugging the headset and sensors, deleting every Oculus related folder, clearing out the registries.

I don't know what else to do/try to complete the installation process.

Like I said before, everything worked perfectly fine before the necessary patch issue.
Ryzen 1700X
Gigabyte AB350N ITX
16GB Corsair RAM
Win 10, 64-bit
EVGA GTX 1080 Ti SC2

30 REPLIES 30

MrTvMan
Level 2
Amazing! Thank you, LZoltowski! I disabled all my firewalls and created the "C:\windows" path and everything worked smoothly

DrVarnick
Level 2
I have issues with th OculusSetup too. at the end of the installation, fails and ask to restart my Computer.
I checked the Log and i see that all installation processes passed except the line "oculus-driver.exe exited with code -1 (failure)"
After that, i see that is rolling back the installation.
I believe that something is wrong with the installation of the oculus-driver.exe.
My Firewall is disabled and the Panda antivirus too.
What else i can do to make it work??

senthilkumar_an
Level 2
install oculus -driver.exe separately and try the installation.
when OculusSetup.exe installation is progress, you can find the driver inside, C:\Program Files\Oculus\Support\oculus-drivers  folder. copy the folder and install it separately. it will work.

skj13
Level 2
Installing Quest 2 PC software.  Keeps hanging during Install phase.  Turned off AV, multiple restarts etc... Setup log shows download or reuse of all components then:

[Debug] [10/16/2020 9:58:09 AM] Installing 'Visual C++ 2013' redistributable. 

and then nothing happens.  

Any thoughts?

gales81
Level 2
So I managed after hundreds of trials. When you start Steam VR app in goggles and the window with "install the drivers" comes out, if you click the link there, it opens new chrome window. And in my case it was the problem, because this is kind of a separate chrome browser and I couldnt even get acces to the downloaded files. What I did was I copied the address to my "normal" chrome, made sure I'm logged into the oculus website and started it from there. And it worked!
I also had the AV and defender turned off ATM

sport.notifier
Level 3
Can anybody help about the restart error?

Arouke
Level 2


Can anybody help about the restart error?



i have same erre 😕

Evados
Level 2
If you get problem to install the link app make sure to disconnect the oculus cable. Install the link application and connect the oculus cable only when it is asked by the installation.

sbaptista11
Level 2

Evados said:

If you get problem to install the link app make sure to disconnect the oculus cable. Install the link application and connect the oculus cable only when it is asked by the installation.


Dude you have no idea how grateful I am to you for this. I spent the better part of two days trying to figure out why the install wasn't working, tried just about every "solution" I could find, and just before I was about to give up, I see this. All this time... all I had to do was unplug a cable... I've never been so angry, yet relieved at the same time. 

HTC_Flames
Level 2
can someone plz help the setup.exe wil not work to even start the install