cancel
Showing results for 
Search instead for 
Did you mean: 

Some apps , Not loading

mbbnyc
Level 2

I have turned on my Oculus Quest 2 after a long break and some purchased apps won't load. The screen goes blank for a second. Then I get the 3 dots hamburger (Horizontally) and then back to my main page (Living room set).

Some apps do run normally and one new one that I bought today ran once fine. I tried it just to get back into it to check for a problem. It gave me the Hamburger icon once then worked a 2nd time.

 

 I have not run my machine a lot this year. I took basically the whole summer off. When I fired it up in Sept. there were some issues and now when I went back today there were these issues.

I am in a new house with new wi-fi but I dont see how that affects it because some apps did work. (Purchased apps & Free Apps) 

 

Is there a "reset" button on this thing ?

 

Thanks,

 

1 REPLY 1

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hi there fellow gamer! Oh no! We understand not having apps that work can be frustrating and we are here to help. 

In certain cases the headset will need an update. Please check if you have currently updated your device. If you have updated your device, try and soft reboot the device. 

To reboot your device:

  1. With your headset on, hold the power button on the right side of your headset down until you're prompted with a shut-down screen.
  2. Select Restart to reboot your Quest 2 or Quest.

If you are still having this problem after the update and soft reboot, please private message us.