cancel
Showing results for 
Search instead for 
Did you mean: 

Sorry, we couldn't install (game) - Potential fix?

ItsKrypt
Level 2
So, I know this is an issue that many people have had in the past. I had the same issue installing Stormland. For one reason or another, still unbeknown to me, I would get this error:
Sorry, we couldn't install Stormland. Visit Oculus Support to get help.
Well, here I was, scouring the forums for a solution. Lots of people had tried lots of things, from as simple as disconnecting and reconnecting their headset, all the way up to a fresh Windows install. Still, nothing had worked (at least not reliably). I decided to find out where the files were downloading to, as per another suggestion and making sure there were no permission conflicts and plentiful free space.
Installing onto a Samsung QVO SSD with 840GB of free space, in a custom made folder simply at:
X:\Oculus
Antivirus (Bitdefender) disabled, no apps running on the Quest in the background and it was connected the entire time with Link enabled.

Still nothing.

I realised that, by some ridiculous design, the game files were deleting themselves after the installation failed, every. Single. Time. After downloading 13.5GB of Stormland 4 times, I decided I would pause the download when it was on around 13.3GB/13.49GB, then find the files, make copies so I wouldn't need to download them again, and if it fails just replace them in the folder where I found them before starting the update. Simple shortcut to save myself some data and time. These files, for me, go to:
X:\Oculus\Software\Staging\(game in question)
Obviously your result will vary depending on where your Oculus games install to. 

The folder was called Insomniac-games-i-28 which is specific for Stormland, and always the same name. So I copied it, and obviously had to have a peak in the folder and see what was in there.
pq9ldw42bj56.png

Hello, an executable. You know what I did here, surely. That executable, literally called Stormland.exe is too tempting to NOT just run it. I ran it as an administrator, and it added Stormland to my Oculus game list. Whenever i run the game, however, it closed immediately. Okay, no surprises there, the files were incomplete, so the install isn't complete either. So I removed it from my library, then copied the entire Insomniac-games-i-28 back into the Staging directory, then started 'installing' the game again. It actually started Verifying the install instead of downloading it. That's odd, I thought. Well, I'll see what happens. 

agmjxped9qca.png

Lo and behold, the game installed perfectly, and runs beautifully, just as it's meant to. No clue what I did, or what the issue was, but perhaps there was some bug in running that executable automatically, and once it had completed the 'install' each time it deleted those Staging files which are just temp files (by design, they're automatically deleted after installation - the issue was that the installation was never working).

Not such a ridiculous design after all, but rather a ridiculous bug within the Oculus software itself (I suspect). I hope this can help somebody else that encounters this issue. No idea if you could replicate this but it sure seems like you can, let me know if it works for you down below.
1 REPLY 1

thatdude90210
Level 4
Holly crap, this works. My issue was a little different. I had backed up my "software" folder but didn't backup the manifest folder so I couldn't do a simple restore. And I've been fighting this stupid "can't install software, please visit support" issue all weekend. This issue is all over google. Support had been no help, just telling me to make sure I had enough HD space, disable antivirus & firewall, etc. Initially I had one program that wouldn't update so they had me wipe my Oculus software folders and reinstall. But the games wouldn't install afterward. 

Finding this, I put my backups from my software folder into the staging folder and they installed correctly, finally. Thank you.