Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Sound stop after seconds or minutes (randomly)

Level 3
I saw that many people had a problem similar to that and tried all the solutions without any success.

I tried uninstalling oculus rift and its driver and reinstalling everything.
I tried disabling all my other audio outputs except Rift Audio
I made sure all the firmware of my devices was up to date

Here's what happens now.
For now, Oculus App is closed.
When I open the windows sound settings on the Playback tab I now see only Rift audio.
I right click on it, go in Advanced and click on the test button.
The sound is going through since I see the green bar and I hear the sound from the rift's headphones.

I now open Oculus App
Then try the test again
It still works, I still see the green bar.
But if I wait long enough, the sound will stop in a game or when I am in oculus home. (It usually is about 15 seconds)
If I press on the test button again, there's nothing. No green. No sound.
If I close Oculus App and do the test again. It works!

So I don't know what is causing that problem. Even the test doesn't work. And it only happens when Oculus App is opened. By default the "Exclusive Mode" is on but I tried unchecking that box since I though maybe an app was taking control of the audio. But it doesn't change anything. I know it's not conflicting with other outputs since I disabled them all except for the Rift... I also made sure the output was set to Rift Audio in Oculus App and also tried mirroring the audio. But nothing is working.

Looks like a bug in the Oculus software 😞 It was working fine before. I'm not sure which update caused that problem... Anyone know any workaround to that problem? Thanks a lot!

Level 3
I have a GTX970 and just saw another post with the same problem and same card. So maybe a problem with a nvidia audio driver... But I disabled it so not sure if relevant...

Level 4
I've had the same NVIDIA drivers for a few weeks now and not had the issue until after I upgraded Oculus to 1.17.  I have tried toggling the audio output for the Rift between mirrored but still had it drop out on me -it took about 15 minutes before I lost sound though.

Level 3
It looks like the sound is freezing. I just managed to make it stop working while there was sound playing. Now the green bar is stuck at a level. The device doesn't make sound, the green bar is just stuck in that position. As soon as I closed Oculus App, the green bar disappeared. So it looks like the app is making the rift output freeze for some reason. This really looks like a software bug now, not much we can do but wait for the next update...

Level 3
Had you tried switching the format to CD quality?
"Try going to playback devices. Select Headphones (Rift Audio). Click on Properties. Then open the Advanced tab, and make sure the Default Format is set to "2 channel, 16 bit, 44100 Hz (CD Quality)". For me, it was set to 48000 Hz for some reason."

Level 4
I'll confirm that format setting to CD quality restored sound without having to restart the Oculus app in my case.  I also just did a few laps in Assetto Corsa without sound cutting out.  Fingers crossed. 

Level 3
That seems to work for me also. Wow. Thanks man. I'll repost if it stop again but for now it seems to work!

Level 2
FWIW, I have the same issue and same video card. I'll get anywhere from 15 seconds to 3 minutes of audio before it cuts out in the Oculus app.  Toggling between audio quality seems to fix it, usually. Occasionally it'll still freeze up.  I just keep the audio properties window open and when it happens: pause the game, toggle quality, and resume the game.

Edit: I continue to have this problem. I tried updating to the latest NVidia drivers, reseating and replugging the HDMI and USB plugs. Different ports, etc... There is no consistent fix that works and stays working. Sound will always drop out with-in 15 minutes. Bummer 😞

Level 2
I have the same problem, year ago

Level 4
Same problem here as well!

The sound on my rift completely drops out after anywhere from 1 minute to 1 hour of use. If the HMD is not "active" (as in, wearing it) the sound will last 1+ hours, but if it's active it usually lasts about 2-3 minutes most of the time. The sound VU meter in Windows "freezes" on whatever sound level was playing at the time - sound continues to play through my normal headphones and/or speakers while the rift just stops.

I just bought a brand new PC and this problem has only started to happen on my BRAND NEW (Windows 10) computer. My 8 year old system (Windows 7) I never had any problem until the mainboard finally gave up on me about 3 weeks ago. The problem started happening immediately after installing the rift on my brand new rig. I reinstalled Windows 10 from scratch at the beginning of all of this thinking something installed badly, yet the problem remained.

So far to resolve the problem myself (with zero luck) I have also tried the following:

- rebooting my PC (the best oculus support website could offer me as a solution (pretty lame))
- 3 different drivers for my sound device including the manufacturer driver from Asus for Realtek sound. The Windows default sound driver, and the nvidia driver that was installed with my graphics card - then tried combinations of most of the following steps with each driver installed.
- removing and disabling ALL other sound devices including headphones and speakers, etc
- Disabling "enhancements" in the audio settings
- Changing sound quality from DVD to CD
- using a passive extension cable for USB and HMDI
- using an active extension cable for USB and HDMI
- using NO extension cable for USB and HDMI
- plugging the headset into USB 3.1
- plugging the headset into USB 3.0
- plugging the headset into USB 2.0
- plugging the headset into a USB 3.0 controller card PCI-E
- plugging the headset into a USB 2.0 controller card PCI-E
- disconnecting EVERYTHING except for the headset from USB, including the sensors, mouse, keyboard, etc
- reinstalling oculus home
- running the oculus driver updater tool
- changing the cable on the HMD from my old (broken LCD) headset that oculus won't supply replacement LCD screens for
- changing USB hub power management settings to never power off
- installing and trying the third party oculus tray tool
- installing a creative labs PCI-E sound card and completely bypassing the onboard sound
- set rift to primary sound device
- set rift not to primary sound device
- uninstalled discord
- uninstalled ASUS AI software
- performed dsim /online /cleanup-image /scanhealth in powershell as admin
- performed dsim /online /cleanup-image /checkhealth in powershell as admin
- performed dsim /online /cleanup-image /restorehealth in powershell as admin
- performed sfc /scannow in powershell as admin
- toggled enabled/disabled audio mirroring in oculus home
- toggled spatial sound on/off
- removed and reattached headphones
- removed headphones and cleaned contacts with isopropal alcohol on a cotton top and reattached
- used headphones from my broken LCD rift
- totally caved in and tried my HMD with the broken left LCD screen to see if maybe my new rift has suddenly had some issue... guess what? SAME PROBLEM!
- probably some other stuff I've forgotten about after the THREE WEEKS I've spent trying to figure this out!

The only way I can get sound back without totally restarting oculus runtime service, or rebooting entire PC etc is to open the sound controls in Windows 10, go to properties of the rift headset and toggle the "disable all enhancements" option in the enhancements tab. If it's on, I turn it off, and vice versa. Sound will then return for a minute or three before doing the exact same thing again.

I'm well an truly over this... this simple problem had rendered my HMD pretty much completely useless now, as sound is kind of a big deal!

Hopefully someone has some answers since this problem easily dates back to early/mid 2016 just by doing some quick google searches. After extensively reading every shred of information I could find about this problem, NONE of the things that people claim fixed their problem seem to have fixed mine, and then-some. I tried every single thing from every support thread, reddit post, steam community suggestion, etc etc.


PC specs:
AMD Ryzen 7 2700X
ROG Strix X470-F Mainboard
16Gb Corsair RGB 3466 DDR4
Gigabyte GTX1060 graphics card (updating to RTX card soon!)
Samsung EVO 470 M.2 500Gb
a bunch of 2-4Tb mechanical SATA drives
900W 80amp Thermaltake PSU

I'm actually going to start my own thread as well, since the OP is more than a year old. Will leave this post here anyway just for anyone wandering the interwebs another two years from now with the same problem, mainly so the can nervously chuckle in dismay.