Showing results for 
Search instead for 
Did you mean: 

Trouble installing Startech USB card.

Level 8
I bought one of these  a little while back and have only just got around to installing it.

Problem is my PC won't boot up at all ie no video even detected, whilst the card is in. I've tried the card powered and unpowered in both my free pci-e slots and no joy. Take the card out, and PC boots up fine again.

My motherboard is an MSI Z97 Gaming 5. The BIOS setup is pretty basic and I can't see anything to suggest that the other pci-e slots might be off.

Power is almost certainly not the issue as I have an 850w supply.

About the only other thing I can think of trying, is taking my video card out and using the on board video to see if it's still causing a problem. But not tonight though, as it's getting too late.

Duff USB card maybe or something else?


Level 4
I have one of these but have an entirely different issue which it think comes down to my mobo but i can work around it.

In your case i can see one issue but i dont know how much it plays in your no boot scenario. All of your pciex16 slots are connected to your CPU. (Gen3 (16,0,0), (8,8,0), (8,4,4)) So when you fit the USB card to either of the other pcie that your graphics card isnt in, then you will be cutting down on your graphics card pcie lanes.

This is likely not a problem in and of itself as i can run mine in my spare CPU connected pcie 16 slot (though it doesnt solve my issue).

My issue with this card, is that it is 4 independent controllers. But unless i completely power down the pc at the wall, it only initialises 1, 2 or 3 of them at random. To get all 4 working, i have to shut down the PC, turn off the wall socket for 15 seconds, then turn all back on again at which point its fine until i shut the PC down where the problem begins again on next boot.

What i can say about startech, (even though they have not yet fixed my issue since i have tried this card in my alternative identical AORUS z370 gaming 7 board to the same effect, but still want to try it in a completely different mobo before i send it back), is that they have exceptional and patient customer service, i had a guy on remote desktop for 30 minutes who was knowledgable and interested in helping, so give em a call.

Level 8
Cheers for the reply. Looks like I'll have to give them a call then.

Level 8
Right, I shall tentatively say, that it looks like I've sorted it.

I rang support and a guy said it's either a case that my hardware isn't compatible or that the card is faulty. He did say to try it in another PC if possible. Doh! I thought, why didn't I think of that? I mean I only worked in IT support for about 12 years. Although doing stuff like this reminds me why I got out of it.

So tried the card in my spare PC, and it works fine. Obviously there is something more to this that I need to look at on my VR PC. So with the card in my VR PC, it isn't booting at all. I'm getting power, fans spinning up etc, but no post beep or video detected. There is, handly enough, a digital readout on the board with debug codes and it's stopping, somewhat obviously, on the initialisation of the PCI-E port the card is plugged into. So it knows it's there, it just can't figure out what to do with it.

I do a little bit of reading up on PCI-E ports and similar problems to my own and figure it has something to do with the bus lane allocation. From a previous look at the bios, I know that by default the motherboard is set to do this automatically, but obviously it can't figure out what to do with the USB card. So I manually set the pci lane configuration to x8/x8/x0 from the x16/x0/x0 that it was auto configuring for the gpu (from what I've read switching from x16 to x8 hardly makes a scrap of difference to the performance, something like a 1% performance hit). A restart and it boots up and I can see the card in the device manager. Success? Hard to tell just yet as I always do another reboot just to check, and..... it stops working again. A couple more tries and no joy.

So another thing the bios auto configures for the pci buses, is what generation the installed cards are. Guessing that the motherboard can't handle that either, I check the online spec sheet for the card to find that it's a gen 2 card (PCI Express Base Specification Rev. 2.0). So I manually set that to gen 2 for that slot, reboot, and it works again! Another reboot, still working! Pop the side back on the case, plug it all back in AND plug the Rift into the newly installed card, and my USB 3 hub into the mainboard's USB socket and fire it back up. Check Oculus Home/devices, all good to go, joystick and throttle all working, success! Hopefully.

Only took 3-4 hours of crawling under my desk pulling plugs and lots of head scratching to sort out. Aren't computers great?  😕