cancel
Showing results for 
Search instead for 
Did you mean: 

USB disconnects still an issue - any solution?

nafester
Level 3
Hi,

So ever since I got the Rift I've had an issue where the USB sensors will disconnect and reconnect instantly - basically Windows plays 2 USB disconnect sounds followed by a connect sound. This never happens when I'm using the Rift, only when it's idle. Doesn't matter whether I have the sensors going in via the Inatek card or my motherboard USB 3. I'm now running 3 sensors and it seems to happen randomly to any one of them.

This has never affected my Rift use as they never disconnect while using it, but the issue is a) the USB disconnect/reconnect sounds are getting really annoying after all this time and b) more importantly, any game I'm playing has its framerate tanked for 10 seconds while the USB thing sorts itself out. Particularly annoying in Street Fighter 5 where a solid 60fps is absolutely mandatory.

This has been going on for ages, has there been any solution or anything that can be done to sort this? Steadily going bananas here.

Thanks!

edit: Just thought it might be worth adding - the disconnects often *appear* to happen when I move about. Like if I sit down/stand up or something like that. I'm not sure if the movement is triggering the sensors to wake up in some fashion, and that causes the misbehaving. Then again sometimes it'll happen when I haven't moved.

Another minor thing. For the most part, the sensor will disconnect, reconnect and then be fine. After enough disconnects though (over the course of a day or two) it'll disconnect and reconnect in such a way that I get a 'Rift Sensor' showing up in my safely remove hardware options. When is shows there, that sensor will stop functioning. I'll then need to restart the computer to get it working again. (Or possibly unplug/replug but that involves getting behind the PC, so balls to that :tongue:)
13 REPLIES 13

cybereality
Level 16
I've seen this disconnect issue on my home machine. It never happens on my work machine, and at home it only happens maybe once or twice a week, so not that frequent. Strangely, I've seen similar issue, where the Windows notification says "Last USB Device has Disconnected" or something like that with the accompanying chime sound, even though Rift isn't plugged in and the Oculus software is uninstalled. So I'm not 100% certain the issue is unique to Oculus, but maybe something in there conflicts somewhere.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

nafester
Level 3
So there's currently no known fix, or anything I can try for this?

dburne
Level 16
Do you have power management disabled for each sensor and the headset?
I know on the Innatek card, it re-enables upon each new boot and has to be disabled again.
The tray tool by ApollyonVR will also disable power management on the Innatek card, can be set to run at startup.
It is available here .

I was pulling my hair out over this after first getting my Rift ( I use the Innatek card), since I grabbed the Tray Tool and set it to disable power management on the Innatek at startup, have not had a disconnect since ( about 2 months).

Don

EVGA Z390 Dark MB | I9 9900k| EVGA 3090 FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |

nafester
Level 3
I remember reading about the tray tool recentlyish. I assume it's not going to fix the issue as when I manually disable power management on the Inatek card, the USB disconnects continue on the same session - i.e. it doesn't fix it until a reboot.

That said, there may be something I'm missing, so I'll download the tool and give it a bash. Thanks for the suggestion!

dburne
Level 16
You are very welcome, hopefully the tray tool will fix yours like it did mine.

Btw - there are two areas in device manager you have to disable the power management, one in the USB root hub, and then under Oculus VR Devices for each sensor you have connected.
I just find running that tray tool with it set to disable power management on the Innatek card at startup to be easy and trouble free - at least for me.

Good luck!
Don

EVGA Z390 Dark MB | I9 9900k| EVGA 3090 FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |

nafester
Level 3
Well, tried the tool for a couple of days. No doubt it's a great bit of software to have - the audio switcher I've found quite helpful as obviously not every game/program does that automatically. Unfortunately it doesn't seem to have made any difference to the USB disconnect issue. Thanks again for the help though.

Any other suggestions from anyone are more than welcome, this issue is really getting very frustrating.

dburne
Level 16

nafester said:

Well, tried the tool for a couple of days. No doubt it's a great bit of software to have - the audio switcher I've found quite helpful as obviously not every game/program does that automatically. Unfortunately it doesn't seem to have made any difference to the USB disconnect issue. Thanks again for the help though.

Any other suggestions from anyone are more than welcome, this issue is really getting very frustrating.



Hmm that is odd, I would have felt pretty certain that was your issue... but with computers who knows. All the symptoms you described in the OP sounded just like what happened to me as well.

You did run the Tray Tool " As Administrator" correct?
You did plug in the power lead for the Innatek card?

Also check the driver version for your Fresco Logic USB driver for the Innatek card. You can check this in device manager, USB Controllers - Fresco Logic USB 3 Root Hub. Right click-properties-driver tab. The latest are I believe 3.6.9.0. dated 8/2/16. The card I got a couple months or so ago shipped with older drivers, and I updated to the newer ones after I got the card installed. I believe the previous version was known to have some issues.

Don

EVGA Z390 Dark MB | I9 9900k| EVGA 3090 FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |

nafester
Level 3
Ran the Tray Tool as admin at first, then enabled startup mode and let it do its thing.

Discovered warnings on first reboot about power options on various USB root hubs - told it to fix them all. No such warnings since. (Also restarted after the warnings were fixed to make sure it had settled).

Inatek card does indeed have a SATA power cable hooked up to it.

Drivers are at 3.6.9.0. I remember reading elsewhere that some people had better luck with - I can't actually remember, earlier drivers, or the drivers provided by Windows Update? Not sure, either way I've tried a different set and that didn't help. I've been on the 3.6.9.0 for a while now.

Just to be clear - and as I want to check if this is absolutely the same issue I had - the disconnects have *never* caused an issue while I'm using the Rift. It's purely a (very, very irritating) idle problem. The USB disconnect/reconnect sound goes off at random times and will, after a few days with no restart, simply cause a random sensor to stop working. Restart always fixes it - though interestingly I have to hit the restart button as when this happens, Win10 hangs on "Restarting your computer" for ages.

For what it's worth. it's been a while, but pre-Touch and 3 sensor setup, I had the same issue. I tried hooking up the 1 sensor to my onboard USB 3 rather than the Inatek and it behaved in exactly the same way.

dburne
Level 16
Yep what you are describing is exactly what happened to me. Sometimes it would even throw  the sensor down into the systray in Windows with the " safely remove device" icon . When it showed up there I knew for sure I was going to have to reboot.


I know you have it set to run at startup, which I do as well.
Try this:
Browse to the OculusTrayTool.exe.
Right click that file, and click on Properties.
Then click on the Compatibility tab.
Down toward the bottom in Settings of that tab, make sure there is a checkmark in " Run this program as an administrator". Click apply, then ok.

Exit out of the Tray Tool if running, then restart it. It has to be run as administrator on each boot. You may have already done all this, just wanted to be sure.

If it is already checked, or if not and it still does not work properly after the above, then it is likely a different issue altogether...

Btw - if you should get a warning about power management after the reboot, I would not choose to fix it. It may just be re-enabling it if you choose to fix it. That may be why it did not work for you...

Don

EVGA Z390 Dark MB | I9 9900k| EVGA 3090 FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |