cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to use "Install on Headset" on Android oculus app after purchasing a game

I recently purchased an oculus quest 2 and I'm unable to use the "Install on Headset" to queue the installation to my headset. After I purchase something on the oculus app from my phone. I click the "Install on Headset", then it shows 3 devices(I only have one device) though, all 3 devices appear to be the same because they all have the same serial number id. Then I click one of the devices and it automatically puts a check mark on all 3. So then I click install and the nothing happens it just goes back to where I can click "Install on Headset" again. So the only way to install the app is to do it on the quest 2 itself. I hope I'm explaining this well and this makes sense. I've already factory reset the device from the device and the oculus app on my phone. But still have the issue. I tried to delete device data from the oculus website but I keep getting an error after putting in the code for remote wipe. Not sure that is what is causing the issue. 

2 REPLIES 2

OculusSupport
Community Manager
Community Manager

Hey there! We see you're having issues installing games to your headset and, the app seems to be recognizing more than one device when you only have one. We want to help you out. We'll need some more information from you, so please send us a PM. Please click here https://ocul.us/OculusCommunitySupport or on our name to get to our profile page, then click "Send a Message" to privately contact us. Please remember, you must be signed into the community first to send us a private message.

 

 

 

 

I have this same problem too but on an iPhone and iPad. I've factory reset and restarted all devices including router, so many times. Nothing worked. I've uninstalled and reinstalled the app, etc. Did you ever get a solution?