Showing results for 
Search instead for 
Did you mean: 

V30 Update WiFi Issues (BUG)

Level 3

After updating to v30 my quest 2 keeps randomly randomly disconnecting from WiFi. And sometimes the WiFi speed will slow down <100 Mbps.


Accepted Solutions

Level 2

It's not Oculus fault, people. It's wifi 6. lol 

What a fanboy. 

View solution in original post


Level 15

Might help if you say if this problem is with Q2 standalone or with Link/Air Link and provide your router/wifi setup.  If you google Quest 2 wifi troubleshooting you may find a number of suggested fixes.  For example;


If you cannot sort this out yourself you are probably best to contact Oculus support and see if they can help.  Good luck sorting this out mate.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

I spent over a hour troubleshooting my WiFi and I didn't find anything wrong. Also I tried to contact oculus support but they kept blaming my router/WiFi and told me to contact my ISP.

Maybe try it at a friend’s house that has good WiFi and see if it works ok there.   Maybe even a hotspot with your smartphone.


You could also try a factory reset and see if this helps.  Easiest to do with you phone app.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

I already did testing on my network with other devices and my network was fine. So the only other possible cause would be the quest 2 update. I know a lot of people who have the same issues. They have done a factory reset and it didn't help at all.

Level 2

Same here, on V29 all was great with my Asus RT-AX58U (ax, 2x2 80MHz), but after update to v30 random Wi-Fi drops occurs (looks like a bug in wireless driver, cause when wifi drops, there is no 5GHz networks in list, but 2.4GHz is here). I use 5GHz only network, so when radio drops - there is a 30-40 sec outage before I can reconnect back, turning Wi-Fi switch off and on usually helps reconnect faster.

@brbsh  Pretty well all the v30 wifi issues I've seen are from those using wifi 6 routers on the 5Ghz band.  My wifi 5 router on v30 continues to work fine with both my Q1 and Q2 on my dedicated 5Ghz band (channel 36/80 btw).  So, maybe there is a driver issue with some wifi 6 routers? 


I also wonder if some of the current wifi problems are caused by people using newer wifi 6 router settings like enabling beam forging and setting antennas to max power mode?  While these setting may improve 5Ghz range, they may also be causing some instability in the 5Ghz signal.  Some devices, like the Q2 may be more susceptible to this than other devices. 


In any case, I hope that those with wifi problems continue to try to work with Oculus Support to see if these can be sorted out.  Good luck and cheers mates.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

There is nothing wrong with my router. Oculus changed something in V30 that causes the issue with WiFi. 

@Afootpluto  Ya, sorry I forgot, always Oculus's fault, lol!

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

Level 4

Oculus changed something with V30, but it also seems to only affect certain routers, some worse than others.


Air Link still works flawlessly with my Q2 and V30 (V31 now) and a Linksys EA6350v3 router, just like it did on all previous Q2 firmware versions. I've had no random disconnects. I run OpenWRT on this router.


My Q2 seems notably worse on my NETGEAR R6260 router though since V30, but worked fine on previous Q2 firmware versions. I've seen a few wireless drops, and Air Link gets intermittent lag. This is the case with OpenWRT on this router; seemingly stock firmware works ok with Air Link, but this router has other issues with stock firmware that makes it unusable.


Both routers are Wifi5, but have totally different SoCs and wireless chipsets/drivers, and quite frankly, I suspect the NETGEAR router is just an oddity by itself (stock firmware is broken with it dropping NAT randomly, and with OpenWRT, mt76 driver isn't the greatest).


So in essence, V30 doesn't universally mean wireless is broken for everyone, but it seems to introduce new issues for certain routers. It's possible some routers can be mitigated by changing some settings, but if you have a router with non-ideal hardware (non-ideal with whatever changed with Quest's V30 firmware), you're likely out of luck currently.