cancel
Showing results for 
Search instead for 
Did you mean: 

Vrcover 5m link cable is not working

DogePowered
Level 2

So i recently bought q2, normally i have rift s but i wanted to make a difference.
The problem is when i plug in to pc, its charging normally, but its not recognizing pc.
I tried with original oculus charging cable and it works fine, also i tried with 3 different pc's and they had the same issue. I tried everything vrcover support said.
Im thinking its faulty product.
What can i do does anybody have the same issue ?

7 REPLIES 7

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey DogePowered! We see you may be having some trouble with connecting your Quest 2 to your PC and we'd like to help. We're understanding that you were able to connect with your Oculus headset cable and we're wondering if it's the Oculus Link that you're having trouble with. So that we can get a better understanding, please answer the following questions:

  • Are you receiving an error message? If so, please respond with a screenshot of the error message(s).
  • What cables have you already tried using?
  • What troubleshooting steps have you tried? 

Once you clarify these details, we will be happy to look into this further for you. 

Same issue here with VR cover cable

TomCgcmfc
Level 15

I have this cable and it works great plugged into my z390 Motherboard usb3.1 gen2 type c port.  Actually performs a little better than my official link cable.  Could be an issue with the pc port or maybe an adapter if you’re using one.  Could be a faulty cable I guess.  Have you tried connecting any other device with this cable?  In any case I’m sure VR Cover will look after you.

 

Edit; I think I needed to unplug the headset and plug it in again for my pc to recognize it.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

PITTCANNA
Level 12

Make sure you don't have air link toggled on within the quest headset.

 

 

Hey there nikola.knight.of.ni, we always want to make sure players can play the games they want. We'll do our absolute best to you back into the game again and get your Oculus experience up to 100%! Below we've outlined some troubleshooting steps you could try to ease any potential link issues.

 

 

Are there any updates to Windows/GPU/USB?

 

Sometimes there may be outdated drivers or pending updates that could interfere with the Link and its performance. I've included a guide on how to check for updates to your drivers here! The article is titled for Rift/Rift S but applies to Quest/Quest 2 as well.

 

For Windows, there's an article on how to check for updates here!

 

If updates are found for either, make sure you restart your PC once they are complete, then try to use Link again.

 

 

Game Mode may conflict with some VR applications.

 

In Windows 10, there is a feature called "Game Mode". Game Mode appears to reduce or eliminate background processes and focuses performance on the active game. This could interfere with the Oculus software, as it needs multiple processes running simultaneously to function properly. Try disabling Game Mode, then attempt using Link again.

 

  • Open the Windows Settings menu
  • Click on Gaming
  • Click Game Mode
  • Toggle Game Mode off

Try another cable

 

Some cables lack the ability to transfer power or data. It's ideal to use the official link cable or a third party USB C cable, and not the charging cable that comes in the box, as this is designed for charging the device and not for link gameplay. While some users may report the charging cable working for link capability, we cannot offer any guarantees.

 

Submit a Support Ticket.

 

Collect Oculus Diagnostic Logs and submit them in a support ticket here so that we may look over them and confirm any conflicting software, PC/System updates and inconsistencies.

 

 


Optional: Bring a Shrubbery

 

If you find your Oculus Link isn't working, you must return here with a shrubbery! One that looks nice of course, and not too expensive. Once you've done that you must find... another shrubbery! Then, when you have found the shrubbery, you must place it beside your first. Only slightly higher, so you get a two-level effect with a little path running down the middle. Then and only then, will you be able to connect to your Oculus Link, to which then you must cut down the mightiest tree in the forest with... a herring!
For clarification, this bit is satire.

Ok, thanks for making me laugh with the last option 😄

Drivers are updated. GameMode is off. I've been using PartyLink so far, but I tripped on the cable and bent and broke it so I got the VRCover one now.

The cable is charging the device, but otherwise I do not get the message to enable Oculus Link on the device nor do I see the device connected on the Oculus hub app on my pc.
Still waiting for a response from VRCover on the issue.

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey nikola.knight.of.ni, thanks for getting back to us on that! Glad we could bring a smile to your face, even with all that's happening! Sounds like you should definitely look into another cable, as the cable you're using might not have a high enough power/data transfer rate for link capabilities. I've had some luck with the Anker cable myself, though definitely wait out that response from VRCover and see what their verdict is before anything. What I did for my personal setup, was grabbed a USB extension cable to act as a breakaway cable and tucked it under a desk leg so I wouldn't trip on it. That way, in the event you trip on the cord itself, it'll separate from the breakaway cable and not damage your headset or force you to play 52 pickup with your computer's side panel.

Let us know what VRCover says and if trying another cable doesn't work for you, that way we can keep working with you to get this resolved.