cancel
Showing results for 
Search instead for 
Did you mean: 

Weird Controller Issues: Link + Quest 2

RelishedCrown
Level 2
I did some searches and I couldn't find anyone else making posts with this issue so hopefully isn't not a one-off thing. 

The Touch controllers which came with my Quest 2 seem to work 100% fine when running native apps; no latency issues, no dropouts, all controls working as intended afaik. However, I have issues when trying to use them in Oculus Link. The controller/controls don't seem to be working 100% as intended. I'll also add that I'm using the official first-party Oculus Link cable which I bought together with my Quest 2 direct from the official Oculus website and everything is up-to-date afaik (I just let everything auto-update). 

When trying to play Half Life: Alyx with continuous locomotion, the joystick works at moving me around but it doesn't follow my headset/controller direction. So I can push forward and I'll go forward but if I for example turn myself around 180 degrees IRL and push forward then I end up going backwards. If I use the joystick to continuous or snap turn, that seems to reset my in-game "direction" then forward is forward again. The same issue is present regardless of if controller or headset relative movement is selected. Not completely unplayable but very annoying since it keeps screwing up my movement and I have to try compensate by joystick turning constantly.

When trying to play SUPERHOT VR (in SteamVR via Oculus Link) throwing things seems completely broken. I'll try throw things but they end up going nowhere or even flying backwards. I think it might be the "release" of the grip getting delayed heavily since I can sometimes get things to go by trying to let go midway through the swing and trying to "follow-through" very far. Being unable to throw just makes the game unplayable when there are levels which require throwing to complete. I don't think it's just a lack of coordination on my part since throwing things seems to work just fine in Half Life: Alyx.

I also tried the VR Benchmark Kanojo in SteamVR (for benchmarking purposes I swear) and I just completely couldn't select anything. I'm aware it's a bit unusual and uses headset direction to control a cursor but I couldn't select anything. B button to bring up the menu worked and tracking of my hands and grip+trigger worked with hands fully represented in game but not the A button and actually selecting menu items so I can't actually start the benchmark run. 

What's more is that everything (control-wise) seems to work just fine if I use the Virtual Desktop App. Movement follows the direction of headset or controller (as selected) in Half Life: Alyx, throwing works much better in SUPERHOT VR (SteamVR) and the benchmark seems to work fully. Virtual Desktop is alright but I prefer the higher visual fidelity, better reliability and lower latency using a wired connection via Oculus Link when I can. So I wonder if this is some dodgy data pass-through in just my own Oculus Link cable or if it's a systemic-problem for everyone with the current version of Oculus Link not being configured correctly to pass through data. 
1 REPLY 1

Hex3552
Level 2

i have the same problem when using quest 2 with link throwing just seems broken does anyone have a fix