cancel
Showing results for 
Search instead for 
Did you mean: 

Why is link not working?

Chris_the_onion
Level 2

So I bought a kiwi cable to connect to my laptop and I've done tests to see if my PC is good enough for VR and if the cable works and on my laptop it says my quest is good to go but when I put on my quest and try to start link I just get an infinite load screen. Here are my laptop specs btw

Asus Tuf F15; gaming laptop

With an RTX 3050 ti

Ryzen 5 5600H

16gb of ram

I've already tried installing both my graphics drivers, Oculus PC app, and updating my quest 2 so if anyone knows how to fix this that would be a great help.

2 REPLIES 2

Freshaflip
Level 2

Im having the same problem, neither link or air link work but they both show in the pc app as there connected but when i connect on quest 2 just get 3 dots flashing from left to right and a message pop up on pc stating theres a problem look at support. Tried everything apart from factory reset my quest 2. reinstalled link drivers and oculus pc app but nothing has worked

OculusSupport
Community Manager
Community Manager

Hey there Chris_the_onion, thanks for reaching out. We see you are having an issue with infinite loading screens using Link with your Quest 2. We'd love to help you get this resolved as we're sure this is a big hindrance to you enjoying the VR world, so we will do our best to ensure this is resolved for you.

 

With this in mind, we'd like you submit a support ticket on our website here: https://ocul.us/ContactSupport so we can investigate this issue further for you so we can explore all possible options and troubleshooting. 

 

Alternatively, you can send us a Private Message here on the forums, to send us a private message, Please click here https://ocul.us/OculusCommunitySupport or on our name to get to our profile page, then click "Send a Message" to privately contact us. Please remember, you must be signed into the community first to send us a private message.