Showing results for 
Search instead for 
Did you mean: 

WiFi connectivity issue With the Quest 2

Level 2

Got the Quest 2 yesterday.  Out of the box, set it up, everything went smooth.  Got it connected, it updated it's firmware, downloaded my first game to the headset, played it fine.  Pulled out my link cable... connected that to my PC... worked perfectly.  Played all my previously downloaded games off of my PC from my RIFT days.  That was fun... Then, I disconnected from my PC, and the Quest 2 will not fully connect to WiFi anymore.  Re-Start the router?  did that.  Try connecting to a different WiFi... did that.  You can connect, get a strong signal, but limited connectivity basically meaning no real connection.  So, I linked it back up to my PC via the link cable... Works fine through my PC. (using my computers WiFi and playing old games... Disconnect it... No stand alone WiFi.  Bear in mind the PC is connected to the very same router.  Not to mention everything else connected to the Router that is working just fine.  Only the Headset seems to be having trouble.  Let me stress... It finds the Router, and recognizes it.  Says strong signal.  Just limited connectivity.  I cannot figure out how to solve this issue. Anyone?


Level 5

Check the date and time on your Quest 2. Unfortunately I'm unaware of how to fix it.

Level 5

OK if it's caused by your date and time being set to a future date, I solved this using the ADB command option in Sidequest and running the command as written here:



This opens the android settings page in the headset which oculus has tried to prevent you from accessing, and from there you select date and time, disable network time, enter the correct date and time, and you can reenable the network time after that if you like. Then forget your existing wifi connection and reconnect.
This fixed it for me.

thank you very much for your help, i had the same problem and couldn't do anything, my quest went crazy. I never would have found this alone.