cancel
Showing results for 
Search instead for 
Did you mean: 

Windows 10 Hibernate Breaks Sensor Drivers

M_Pizzle_McDizz
Level 3
Inconvenient for people who put their computer into hibernate mode. The drivers for the sensors appear to "break" when the computer goes into hibernation, even when Oculus is closed. Every time it requires a Beta "Oculus Restart" in order to get the sensors to be detected again. Would be nice to have the devices just work right out of hibernation.
8 REPLIES 8

cybereality
Level 15
I use sleep on my machine and it seems to work fine. Can you try that instead?
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

danknugz
Level 9
hibernation writes memory to disk sleep doesnt, hibernation uses less power, i dont think thats a real solution for him
A: Because it messes up the order in which people normally read text. Q: Why is top-posting such a bad thing? A: Top-posting. Q: What is the most annoying thing on forums?

M_Pizzle_McDizz
Level 3
I'm aware of the difference between Sleep and Hibernate, but I prefer Hibernate for several reasons.
  1. As danknugz mentioned, it's writes to disk, so I don't have to worry about losing power (and I save a little in the process).
  2. I have that G Skill RAM that has LED's on it if the RAM gets power. Sleep mode keeps those bad boys on when I don't want it to.
  3. But often when I send my computer into Sleep mode, it starts back up after a minute. One of my USB devices (very possibly the Rift) is sending a wake signal to the computer after I put it to sleep.
Hibernate is just the superior mode to use when not at your computer, when it works right.

LZoltowski
Volunteer Moderator
Volunteer Moderator
I have seen this issue before and not with Oculus but other USB devices, when the PC hibernates it writes all data to disk, including device enumeration, IPD, etc ... when you resume windows the state is loaded with stored IPD's etc for all devices. Now ... on the hardware level, those devices are given a new location in the hierarchy but they don't match the ones that were stored and refuse to work. Not all USB devices support hibernation states and or dont wake in an identical state to the one that was hibernated. You could try a workaround:

Run registry editor:
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Executive
In the details pane, right-click AdditionalCriticalWorkerThreads, and then click Modify.
In the Value data box, type 2, and then click OK
Restart

or try this, I know its Win 7 but the same issue persists on Windows 10 on certain configurations.

https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/usb-ports-not-working-after-hib...

TO help mitigate waking from sleep follow this handy answer:
https://superuser.com/questions/973009/conclusively-stop-wake-timers-from-waking-windows-10-desktop
Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

Be kind to one another 🙂

M_Pizzle_McDizz
Level 3
Hmm, thanks for the suggestions LZoltowski. I've tried the first two suggestions to handle sensors breaking on hibernation. Unfortunately that did not seem to fix it, but I will try your alternate suggestion for Sleep. Appreciate the long, thought out response though.

OmegaM4N
Level 11
Here is another little thing to ponder which i came across the other day, when i wake my PC from sleep and start Oculus sometimes the sensors would be showing as poor tracking, then i found out that if the headset is not within the sensors tracking on wakeup it will always show as poor tracking, but if it is seen by the sensors on wakeup everything is fine, i tried this a few times and it alway came out the same way.
CV1/Vive-knuckles)/Dell Vr Visor/Go/Quest II/ PSVR.

LZoltowski
Volunteer Moderator
Volunteer Moderator
Has anyone tried disabling Fast Startup? It fixed my sleep/wake issues with the headset.

After PC wake my Rift would have an orange light and required a reboot to get it to work again, disabling it solved the issue:

power options

available options

fast startup

Do not reboot, perform a shutdown, wait a few secs and start up again.
Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

Be kind to one another 🙂

Aminpro
Level 2

I am also having this problem where the camera will stop if I wake my PC from hibernation. The only workaround is to restart the Oculus service manually for it to work again. 

 

I hope they can fix this bug.