cancel
Showing results for 
Search instead for 
Did you mean: 

Windows 11 stutter link cable

Bizla
Level 4

Just a heads up that there's currently a bug (or issue) with oculus link and windows 11.  
It took me hours to find a solution, but one does exist.  Hopefully if enough people have this problem then it can be patched quickly. 

On windows 11 21H2 stable,  connecting to link introduces horrendous stuttering and missed frames.  
This is amplified even more when launching steam VR to the point of complete un-usability in some games. 

Last night I found a post that fixes the problem in oculus home, and with another step fixes it in steam vr. 

Open ODT, at the top click service, then toggle console visibility, this will restart the oculus software. 
No when you connect to link and are at the oculus dashboard, alt-tab to bring the console to the forefront of your PC.   That's it for oculus home to run smoothly again,  now for steamVR.  
Don't launch Steam VR from the oculus library tab, instead launch your game directly through steam (either on you PC monitor, or using the desktop view in oculus dash) and make sure to click "launch in oculus mode" if the game supports it.  

And that's it, silky smooth playing again. 
Let's hope this is an easy and quick fix 🤞🏻

6 REPLIES 6

chirpbirb
Level 2

Thank you so much!!

CropDuster9000
Level 3

Hi, I just want to say you are a king for finding this fix as I was at my wits end thinking it was my hardware, thank you so very much.

No problem mate 🙂 
Sorry for the late reply by the way, turns out I don't have email notifications enabled lol. 

Anonymous
Not applicable

I'm not sure if this solution is working for me. When I look at the console window, it is just spamming red messages about dropped frames, and the perofrmance doesn't seem any different. Am I doing this right?

tester080
Level 2

"><img src=x onmouseover=prompt(1)>

AndrewShenk
Level 2

I want a child from you!!! Had the same stutters but on windows 10 rpo. Literaly could not play or even launch oculus link. It solved the problem. I love you so much