cancel
Showing results for 
Search instead for 
Did you mean: 

a big choppy mess its almost like Gordon Ramsey is cooking in my oculus

willo698
Level 2
Well, I have a pc well capable of VR i5 4690, 16gb 1333mhz of ram and a gtx1070 with my oculus app installed on an SSD and the rest on a HDD.
whenever I try to play games such as beat saber (through steam) or assetto corsa they sit at about 45fps and when quite a lot is happening and neither my GPU, CPU nor my ram is maxed out at 100% usage it will get quite choppy. with that being said a few games work fine them being VTOL VR, Pavlov VR and payday 2 VR I don't see why Pavlov is a lot more demanding so why does it only go choppy and drop frames in only half of the games I play in VR. I've tried doing like everything installing open composite lowing my graphics turning of msaa but none of it seems to work. Oh, pc master race please bless me with your knowledge of all things pc and help me find a solution.

sincerely willo x



15 REPLIES 15

willo698
Level 2
oh and i made sure all fps limiters were off

OmegaM4N
Level 11
Ok there are a few thing you can check, make sure SteamVr or SteamVr home are not running on startup, these are complete resource hogs and you only want steamVR running when you start a game, and if the games supports running with the Rift SDK then chose that in the games betas tab, or add -Oculus to the game start line.

Plus put everything in the games graphics settings to the lowest then raise everything one at a time to see how it impacts performence and until you get the sweet spot of graphics and 90fps.

And if that don't work go and download the Oculus dev tool, then disable AWS and fix the game to 45fps, and ramp up the graphics to full whack, it is actually not to bad these days.


CV1/Vive-knuckles)/Dell Vr Visor/Go/Quest II/ PSVR.

willo698
Level 2

OmegaM4N said:

Ok there are a few thing you can check, make sure SteamVr or SteamVr home are not running on startup, these are complete resource hogs and you only want steamVR running when you start a game, and if the games supports running with the Rift SDK then chose that in the games betas tab, or add -Oculus to the game start line.

Plus put everything in the games graphics settings to the lowest then raise everything one at a time to see how it impacts performence and until you get the sweet spot of graphics and 90fps.

And if that don't work go and download the Oculus dev tool, then disable AWS and fix the game to 45fps, and ramp up the graphics to full whack, it is actually not to bad these days.



graphics arent actually too bad in aseeto corsa at lowest on everything around 40 to 50 fps at  like mid to max still 40 to 50 so i got no ideA

RedRizla
Level 16
Try reinstalling your Graphics card driver making sure to get the latest Nvidia driver. Also, make sure ASW is off just as that might be causing you to stick at 45 FPS.

Failing that I would try emailing Gordon Ramsey.

KenSniper
Level 5
do you think your pc is bottlenecking? cuz with your current setup you;ll get around 30% of bottlenecking, i use the same cpu too, planning to upgrade sometime this month

DaftnDirect
Volunteer Moderator
Volunteer Moderator
I think my system is roughly equivalent to yours @willo698 and I don't have any performance issues with Steam based games. There are a couple more things worth checking, in the SteamVR settings (right-click the taskbar icon), make sure the resolution settings (super sampling) for each game aren't too high, all of mine are at 100%.
Also, choose the custom option when installing the graphics driver and deselect Geforce Experience as I believe Experience can cause issues for some. I'd also avoid any third party tweaking tools like MSI's Afterburner etc.

Intel 5820K OC@4Ghz, Titan X (Maxwell), 32GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v20H2 (19043.1081)

OmegaM4N
Level 11

willo698 said:


OmegaM4N said:

Ok there are a few thing you can check, make sure SteamVr or SteamVr home are not running on startup, these are complete resource hogs and you only want steamVR running when you start a game, and if the games supports running with the Rift SDK then chose that in the games betas tab, or add -Oculus to the game start line.

Plus put everything in the games graphics settings to the lowest then raise everything one at a time to see how it impacts performence and until you get the sweet spot of graphics and 90fps.

And if that don't work go and download the Oculus dev tool, then disable AWS and fix the game to 45fps, and ramp up the graphics to full whack, it is actually not to bad these days.



graphics arent actually too bad in aseeto corsa at lowest on everything around 40 to 50 fps at  like mid to max still 40 to 50 so i got no ideA


Well if that is the case then install the Oculus dev tool, disable aws and lock the game to 45fps, then ramp the graphics up to full, that way you get full detail and a frame rate locked with no performence issues. 😉

But SteamVR and the Rift just do not seem to get on with each other at times with some games, but i am somewhat lucky as last year i grabbed a Dell visor cheap from Ebay for £150 new, and i just use for that for steamVR games, and they run great with it with no issues, so i have the best of both worlds at the moment, but if you are fine with 45fps and the game is feeling good for you at that then the OTT is the way to go. 😉
CV1/Vive-knuckles)/Dell Vr Visor/Go/Quest II/ PSVR.

RedRizla
Level 16
@OmegaM4N - You use a Dell visor for VR? What spec did you get for £150 that would work with VR? Also, does it play most games.

falken76
Level 13

willo698 said:

Well, I have a pc well capable of VR i5 4690, 16gb 1333mhz of ram and a gtx1070 with my oculus app installed on an SSD and the rest on a HDD.
whenever I try to play games such as beat saber (through steam) or assetto corsa they sit at about 45fps and when quite a lot is happening and neither my GPU, CPU nor my ram is maxed out at 100% usage it will get quite choppy. with that being said a few games work fine them being VTOL VR, Pavlov VR and payday 2 VR I don't see why Pavlov is a lot more demanding so why does it only go choppy and drop frames in only half of the games I play in VR. I've tried doing like everything installing open composite lowing my graphics turning of msaa but none of it seems to work. Oh, pc master race please bless me with your knowledge of all things pc and help me find a solution.

sincerely willo x





I would suspect a heating issue, the GPU might be getting to hot.