cancel
Showing results for 
Search instead for 
Did you mean: 

can't set oculus as active openxr runtime

jeevil
Level 2

jeevil_0-1635902283795.png

i have a quest 2 and use it on link but it wont work at all because when i click the button here it just does nothing

 

in the quest when i click enable link it loads for a few seconds and just reloads the home area (nothing happens)

please help my quest 2 is unusable for pcvr like this and it seems like such a simple thing

17 REPLIES 17

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hello jeevil! Let's troubleshoot this problem together and get Link fully working with your Quest 2. Here are some things you can try:

  • Ensure you are using the Oculus Link cable, and not the included charging cable or any other cable.
  • Restart the headset and try connecting again with only the keyboard and mouse plugged into your PC.
  • Ensure your GPU drivers and Oculus drivers are fully up to date.
  • Repair the Oculus PC app by following the instructions HERE.
  • Confirm your USB power settings by following these steps:
    • Open Device Manager.
    • Locate your USB ports - Expand the universal serial bus controller section at the bottom of the list. Look for the "USB 3.0/3.1/3.10 eXtensible" items.
    • Right click and select Properties.
    • Navigate to Power Management.
    • Ensure that the options to save power are deselected.
      • Not all of these listings will have these Power Management options, so skip and move onto the next item in the list until completed.

If you need additional help beyond these steps, feel free to send us a PM or click HERE to submit a support ticket. We want to help get PC VR working for you as soon as possible. Thanks!

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hello! Just checking back in and wanted to see if your issue was resolved.

CWeseloh
Level 2

I'm having a similar issue.  Clicking the "Set Oculus as Active" doesn't do anything or generate any error messages.  My software drivers are up to date, etc.

gl0ri0us
Level 3

Same problem here.

aiddun
Level 3

Same problem here

 

kalle.giesbert
Level 3

Same problem here. The button is inactive, no error message. Went through all steps mentioned by Oculus support above and all seemed alright, but cannot set Oculus as default OpenXR runtime. 

PS actually using Rift, not Quest, but the problem with the App is the same 

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey everyone, if the previous troubleshooting steps didn't work to set Oculus as active OpenXR runtime, we have a couple more options to try. Some people have found the following to be helpful:

 

  • If there are multiple accounts associated with your device, use the administrator account to "Set Oculus as active".
  • Open Oculus app > Go to Settings > Select Beta > OpenXR Runtime > Set Oculus as active

We hope this helps! If you are still having issues after these steps, you can reach out to the developers of OpenXR here: https://www.khronos.org/about/contact/

CWeseloh
Level 2

I'm unable to login to the computer with an official Admin account due to this being a corporate laptop.  I tried opening the Oculus application with the "Run as Administrator" option which should have the same effect, and that didn't help.  

 

The "Set Oculus as active" option is no longer on the Beta tab.  It's found under the General tab.  That's the button that we are all saying doesn't work.

 

My understanding is that this feature sets a registry value, so this definitely sounds like an issue with the Oculus software, not something that OpenXR would fix.  Please explain why a developer at OpenXR would be able to help fix a button in the Oculus application.