cancel
Showing results for 
Search instead for 
Did you mean: 

cannot install rift software on windows 10

terrymccann
Level 2

I have tried fresh installs of windows 10 pro and home on my PC and connected only a keyboard and mouse, disabled defender and firewall, tried installing on a non C;\drive. In short I have tried everything suggested in this forum but the Oculus software  refuses to install, always with the DaybreakNative.dll it fails. 

 

see below

Please help.

 

[24/05/2022 07:47:23] Removing working directory.
[Warning] [24/05/2022 07:47:23] Exception deleting 'C:\Users\john\AppData\Local\Temp\OculusSetup-87ca7d60-8718-4a3a-bcdb-281ef8b1d1f0':
System.UnauthorizedAccessException: Access to the path 'DaybreakNative.dll' is denied.
at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive, Boolean throwOnTopLevelDirectoryNotFound, WIN32_FIND_DATA& data)
at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost)
at Dawn.Mixins.ReallyDeleteDirectory(String path)
[Debug] [24/05/2022 07:47:23] Scheduling delete of 'C:\Users\john\AppData\Local\Temp\OculusSetup-87ca7d60-8718-4a3a-bcdb-281ef8b1d1f0' on next reboot.
[Debug] [24/05/2022 07:47:23] Exiting with code 1.

3 REPLIES 3

OculusSupport
Community Manager
Community Manager

Hey there, terrymccann! We never like to hear about folks being unable to get their apps downloaded. Let's take a look and see what's tripping that app up. The first thing that usually pops up is storage space. Do you know how much free space you have available in your C drive?

 

If you have enough free space but are still struggling with that download, follow the steps below to completely remove the software and restart with a fresh install.

 

1. Disconnect your computer from the internet.

2. Backup any necessary content.

     • You can find steps on how to do so by clicking here

3. Reboot into Safe Mode.

4. Uninstall Oculus PC app using the Control Panel.

5. Delete all Oculus folders from the following folder:

    • C:\Program Files

6. Remove any Oculus folders from the following locations:

    • C:\Users\YourUserProfile\AppData  

    • C:\Users\YourUserProfile\AppData\Local 

    • C:\Users\YourUserProfile\AppData\LocalLow

    • C:\Users\YourUserProfile\AppData\Roaming

    • C:\OculusSetup-DownloadCache

7. Restart your computer in normal mode.

8. Reconnect your computer to the internet.

9. Install Oculus PC app again using the setup tool from our website here

10. Run the app as "Administrator"

 

Let us know how it goes. Your Meta Store Support team is standing by and ready to assist!

This failed again, I beleive its that the app hasn't been updated for new versions of windows 10,  1909 which may have  put extra security on the appdata folder

I installed an image which had windows 10 version 1509 and it installed without a problem

Yikes! We will need our team of specialist to assist and investigate further. Please click this link here, we ask that you share every detail with our team so that we will be able to provide you with a possible solution. We hope to hear back from you soon!