cancel
Showing results for 
Search instead for 
Did you mean: 

oculus go browser not working

elvedhel
Level 4

browser has suddenly stopped working on oculus go, no updates so its not thgat, crashes whenever you try to open vr. very annoying tried to re pair to app but app wont go past the heath and safety acknowledge button on set up and factpry reset isnt working in the go either.. have lots of paid apps so dont want to go down the delte data option as dont want to risk losing all ive paid for.

371 REPLIES 371

Try first these steps: enable the developer mode on your Oculus Go, then you should be able to access your browser under the unknown sources

then you should be able to access your browser under the unknown sources,

cogwheel
Level 4
Even though I mentioned oculus go in 2 of my help requests they have twice sent solutions for the newer models???
No good.

Anonymous
Not applicable

WTF

Anonymous
Not applicable

Mine too!!

wesleyD2
Level 2

Same problem with my 'Oculus Go' .... also tried factory reset but the problem is still there.

CANT EVEN DO THAT AS DEVICE REFUSES TO PAIR IN THE APP. can find it via the serial number but wont actually coonect though i doubt dev mode will help anyway.  a vr headset where you cant actually watch vr in the embedded browser. well done oculus you really have screwed people over and your customer support is worse than useless. time to consider legal action

elvedhel
Level 4

 further now add insult to injury, the go wont connect to the app, shows as connected via bluetooth and ive tried rebooting both go and phone and reseting that, but still the app wont find it despite it being paired to the phone, so last resort do yet another factory reset, go to the account page and my device on the web and chose the delete data, get sent the verifcation code, put the code in and guess what... another error 

 

elvedhel_0-1642723518561.jpeg

 

Oculus Go
1KWPH802TC8256
DELETE DEVICE DATA
 
 

An unknown error has occurred.

 

so not only is VR **bleep**ed, the appis **bleep**ed and you now cant even reset device.. and it gets better, click on support to raise a ticket... and the page is blanked out.. i guess oculus rather than deal with the problems bury there head up there arse instead in the hope that go users will do just that.. and go .

Jade_Marmoset
Level 3

I've done a little back and forth with support. I emailed them a link to this thread. The response I got back thanked me for linking them to this thread then they gave instructions to repair the Oculus PC app and download software for the Oculus Rift S. I've never had my Go linked to a PC and I don't own a Rift. Support is less than helpful with this issue.

OndaNegra
Level 4

Yay! This is some 2020 level bull**bleep**; dismissal on full display. The only thing left for them to do is sing & dance mocking their own inefficiency.