cancel
Showing results for 
Search instead for 
Did you mean: 

oculus service kills webcam

mtojay
Level 2
having my rift for 3 days now i finally wanted to make a video with commentary. i bought a cam microsoft live hd3000 last month for that purpose. problem is i cant use it in combination with the oculus.

i have to kill the oculus service from the taskmanager to have access to the webcam (that kills the rift functionallity obviously). otherwise i cant access it at all. it seems as if the oculus drivers use it somehow.

does anybody know how i can use both?

greetings
mtojay
5 REPLIES 5

richhard1
Level 4
Pretty much most logitech equipment is affected by the oculus unit, drivers and software.

Best to stop all of these services until oculus release new firmware/software which ignore/non-conflict with them. it's basically anything that tracks, like trackir sensors, cameras, mouses, keyboards etc.
I7-4790K - GTX980ti - 32GB - PB287Q - G502 - A50 - GAMEZ4RO - G19s - E17k - Xonar7.1 - Xenyx502 - AT2050 - H105 - T300RS - XBox1Elite - X55- 4K/DK2/CV1/VIVE

Anonymous
Not applicable
I have the same problem, I might actually have bought a replacement camera unbeknownst it was the DK2 that made my old one unresponsive! It was still five years old so fine, I needed a new one anyway 😛

In any case, it acts like this for me. Boot anything using the DK2 and the tracking camera is activated. But, if I while running that try to view the webcam or use it while streaming, it just restarts repeatedly and then shuts down. If I quit out of the VR app I can then use my webcam without issues again.

If I already am using my webcam, it works just fine, and boot a DK2 enabled application... I will get no positional tracking instead, the tracking camera just will not light up, this while my webcam will keep working no issues.

I really hope this issue will be adressed at some point, right now my webcam is useless for streaming VR (not that I have any viewers) as I cannot get positional tracking at the same time 😛 The camera I got now is a Logitech C930e, before that I had a Logitech QuickCam Pro 9000 (!) which I think worked with the DK2 up to a few weeks ago.

TEF2one
Level 2
Any update?
The issue still appears to be present 6 years later!!!

kojack
Volunteer Moderator
Volunteer Moderator
Some more details might help. This thread was about a 6 year old developer kit running on the 0.x runtime that was abandoned in 2016. The software is very different now.

Author: Oculus Monitor,  Auto Oculus Touch,  Forum Dark Mode, Phantom Touch Remover,  X-Plane Fixer
Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2

Anonymous
Not applicable

a year later and its still not fixed tho :v