cancel
Showing results for 
Search instead for 
Did you mean: 

"Can't reach Oculus service" on Windows 11 Pro w/ Nvidia 510.10 drivers

highlytechnical
Level 3

Tried repair, tried to clear system cache and temp files, tried uninstall/reinstall, tried to use the 2018 patch, nothing seems to be working.

 

EDIT: After reading through the logs in C:\Users\(my username)\AppData\Local\Oculus it looks like the following error is in the log:

 

[Debug] [2021-10-17 12:22:05 PM]
status: True
[Info] [2021-10-17 12:22:05 PM] Install Complete: Success
Error Code: 0
Install Step: InstallDone
Sub Install Step:
Severity: Info
Line Number: 382
Caller: Install
ODI Version: 1.21.5.0
File Path: D:\ovrsource-null-hg\arvr\projects\oculus_pc_infra\Support\OculusDriverInstaller\OculusDriverInstaller\Installer.cs
[Warning] [2021-10-17 12:22:05 PM] Exception starting service 'OVRService'. : The specified service does not exist as an installed service

 

However I can see that the "runtime" service is running in local processes, but attempting to start the "library" service throws an error code 18...

 

EDIT 2: While waiting for a PM back from the Oculus team, I did some more debug checking (rolled back Nvidia drivers from 510.10 to 496.13, checked the registry paths, tried to set the OVRLibraryService.exe to start automatically and as "local system" which didn't work...so back to a fresh Oculus install) and found this in the logs. Which of course still seem to show that the Runtime service is able to run properly, but the Library service is still having an issue running under the default "NT Service\OVRLibraryService" user settings.

 

[Debug] [2021-10-18 2:57:18 PM] Starting up OVRLibraryService v1.16.0.0.
[Debug] [2021-10-18 2:57:18 PM] Starting up.
[Debug] [2021-10-18 2:57:18 PM] OVRLibraryService was invoked with no arguments. Exiting.

[Debug] [2021-10-18 2:59:03 PM] Starting up OVRLibraryService v1.16.0.0.
[Debug] [2021-10-18 2:59:03 PM] Starting up.
[Warning] [2021-10-18 2:59:03 PM] IPC connection attempt failed!
[Debug] [2021-10-18 2:59:03 PM] IPC thread running; waiting for Oaf to connect.
[Debug] [2021-10-18 2:59:03 PM] App libraries for this user: [CORE_DATA]
[Debug] [2021-10-18 2:59:03 PM] OVRLibraryService starting in service mode. Arguments: [restart-service]
[Debug] [2021-10-18 2:59:03 PM] Creating NTFS transaction.
[Debug] [2021-10-18 2:59:03 PM] Waiting for service 'OVRService' to stop.
[Debug] [2021-10-18 2:59:03 PM] Service 'OVRService' is now Stopped.
[Debug] [2021-10-18 2:59:03 PM] Attempting to start service 'OVRService'.
[Debug] [2021-10-18 2:59:03 PM] Service 'OVRService' is now Running.
[Debug] [2021-10-18 2:59:03 PM] Committing changes.
[Debug] [2021-10-18 2:59:03 PM] Exiting with code 0 (Success)

1 ACCEPTED SOLUTION

Accepted Solutions

hello had the same problem the problem was windows 11 today a new update came out please check if there is an update since it works for me again

View solution in original post

34 REPLIES 34

Warhead777
Level 4

I have the exact same problem. Hoping someone out there can help

Same issue here, stopped working in Win11. Troubleshooted yesterday with Oculus support and got to the point that the we uninstalled the software. And now it is not even possible to install it again, "Sorry, we encountered an error during installation" 
Anybody that has solved the issue?

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there, thanks for reaching out. We see that you are having issues with running Oculus Link on Windows 11. We're sure you'd like the situation to be resolved so you can see what new features Windows 11 has to offer but currently Oculus has not released the updates and drivers that support Windows 11 fully. Until the updates are released, you may continue to experience issues while using Oculus Link on Windows 11. We recommend rolling back your Windows update to one supported by Oculus or waiting until the update is officially released.

Warhead777
Level 4

It's not just that - it's a matter of the fact that we cant install the client - at all - And, for all the people that say launch Virtual Desktop and launch Vive VR that way? Yeah, it doesnt even detect an Oculus is installed, because well, the software isn't. The closest I have come is showing it as a USB device in Device Manager. Anyone else got at least Steam Working with it under Windows 11 / NVIDIA ?

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there, thanks for clearing that up. Have you found that the issue is only happening on Windows 11 or has the issue been ongoing since before you updated to Windows 11? This will help us determine if the issue is software related or potentially hardware related. 

 

We also recommend sending us a PM, you can do so by clicking here https://ocul.us/OculusCommunitySupport or on our name to get to our profile page, then click "Send a Message" to privately contact us. Please remember, you must be signed into the community first to send us a private message.

 

We'd like to get the bottom of this problem so you can finally enjoy the Virtual World again!

Hey community manager, the issue started around the 15th with the 22478.1000 Windows 11 build and was previously working on older builds of Windows 11. As I've interpreted the error log, it looks like an issue with the VR Library Service not being able to start/run automatically. 

Screenshot 2021-10-17 185628.jpg

I've been attempting to get somewhere with this as well, but it looks like the Oculus app is what passes hardware info that can be used by SteamVR. So it looks like unless there's a workaround/fix for the running service, the hardware can't be used outside of the Oculus app.

Yes, I am having the same problem. I am also getting a 404 error for the oculus support page. 

The problem is not simply Oculus Link - it is installing the Oculus App. The app crashed and tried to repair itself and now will not install at all. I can work without Oculus link, but now cannot install the Oculus App on the system.