cancel
Showing results for 
Search instead for 
Did you mean: 

"Check Your Setup" CV1 External Camera "Searching Windows Update..."

Infinite
Level 2
Hi. I cannot install the CV1. The Oculus software is stuck in a loop on "Check Your Setup". I cannot get out of this mode to check any settings or hardware statuses. I'm certain the external tracking camera is also not installed correctly.

I can also see in Device Manager CV1 External Camera a yellow triangle with the exclamation mark. When I force Uninstal I get CV1 External Camera "Searching Windows Update..." Windows is stuck trying to get the driver. It eventually fails with No driver found. But it doesn't matter as I cannot do anything else because Oculus is stuck at "Check Your Setup" page.

Where can I download the CV1 External Camera driver?

In the past I have installed a multiple DK1's, multiple DK2's, GearVR, multiple VIVE's and VIVE Pre. The CV1 so far has been a nightmare to get working. I haven't seen many others with this bug.

What causes this "Check Your Setup" software loop. How do I get out of it? There is no back button or settings button. No icon tray to back end settings. I've I'm struggling with this as a developer, how the hell are consumers going to manage?

Why can't Windows find the driver?

I have updated Win7 to the latest patches, I've downloaded the latest Fresco USB3 drivers. I've tried USB2 and USB3. I've tried to uninstall Oculus and re-install only to be greeted once again with "Check Your Setup"

Can anyone help?

http://www.ir-ltd.net/uploads/checkyoursetup.jpg

_________________________________________________ I N F I N I T E www.ir-ltd.net
44 REPLIES 44

Infinite
Level 2


Can you please provide the log files I requested (just scroll up for the instructions)? That will help me in having the engineering here try to diagnose the problem. Thanks.


Yes I have. Please can you confirm receipt. I am getting no where here and support (ticket) have not helped at all.
_________________________________________________ I N F I N I T E www.ir-ltd.net

Infinite
Level 2
To anyone else having issues with their tracker install, this solved my problems http://www.amazon.co.uk/Cord-free-Expansion-Controller-Additional-Connection/dp/B00JEVLCZI (thanks to DrashVR)

_________________________________________________ I N F I N I T E www.ir-ltd.net

DrOculus
Level 5

Infinite said:

To anyone else having issues with their tracker install, this solved my problems http://www.amazon.co.uk/Cord-free-Expansion-Controller-Additional-Connection/dp/B00JEVLCZI (thanks to DrashVR)



Glad you got sorted in the end Infinite, as i remember you were in the UK and people have asked about working USB 3.0 expansion cards but only got referenced one that was available outside UK so hopefully this will help others too.

Chivas
Level 5
I'm also stuck in the same loop.  Windows 10 64bit  All OK in the Device Manager.  Oculus app shows green OK for the HDMI and both USB2.  The light is ON on the tracking camera, the headset light is on, the display is working, internal headset tracking is working.  BUT the camera doesn't see the headset, and stuck in the check camera is pointing at the headset loop.

Chivas
Level 5
I just ordered the USB3 expansion card, as I need one anyway, but not so sure that is my problem, as  my system, and Oculus app appears to see the sensor, and camera OK.

Chivas
Level 5
So when you installed the USB expansion, did the Oculus app take you to the same Check Setup screen, and it worked this time.  Were you able to thru the whole  Start setup again and check IPD setup, I never got that far.?

cybereality
Level 16
Sorry for the delay. I've been a little behind answering PMs.
Glad you found a solution.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

Infinite
Level 2
@Chivas, if your stuck in that same loop as I had you can try what Cybereality suggested:

"Can you try these steps?

1. Stop the Oculus service (using services.msc)
2. Delete AppData\Roaming\Oculus (in C:\Users\YourName)
3. Restart the Oculus service, which should also relaunch the Oculus app

You
should be prompted to sign in again and should no longer be stuck on
the VR sensor setup step. However, if the sensor driver is still not
installed properly, you may face other issues at this point."

After that I could repeatedly run through the setup procedure to get everything working bit by bit.


_________________________________________________ I N F I N I T E www.ir-ltd.net

VannoVr
Level 2
I'm having the same issue as @Infinite.
Using his sensor screen shot
I tried uninstalling the driver, updating the driver, rebooting the server but CV1 External Camera is not recognized. I also ran the oculus-driver.exe command from the command line but it returned to the prompt without any drivers being installed.

I tried all 4 USB3's and 4 USB 2's.  The Headset works on the USB3's.  As of now the device drivers are not being recognized.  If the drivers aren't recognized, is this a USB hardware issue ?
I can order a new set USB expansion card but there's no guarantee it'll work, and if it didn't I'd have to send it back and order another(?)
Any other suggestions?

VannoVr
Level 2
After several hours of messing around I've finally got the sensor issue resolved by using the information posted in this thread.
Steps:
1. Open the Device Manager
2. Delete the CV1 camera device under Other devices
3. With the camera still plugged in run the oculus-driver.exe command.
    I could see the mouse curser had a waiting / spinning pointer so I knew it was installing something.
4. The device now shows up under Device Manager > Oculus VR Devices > 'Rift Sensor'
5. Stop the Oculus service (using services.msc)
6. Delete AppData\Roaming\Oculus (in C:\Users\YourName)
7. Restart the Oculus service which launches the Oculus setup app
8. Completed the Oculus setup configuration successfully

Thanks for the help