Showing results for 
Search instead for 
Did you mean: 

"Invalid handle specified" when accessing SensorFusion

Level 2
I get the following error when I try to access SensorFusion functions like .IsAttachedToSensor() or .GetOrientation().GetEulerAngles<>()
First-chance exception at Project.exe: An invalid handle was specified.

I created a minimal bugging example for you (you'll need Qt5.x to try it), but it also happens in the parent project (you'll also need Coin3D for that):

The strange thing is, I posted this project in the Oculus Integrations subforum when it ran fine, so I tried the old version from github, but now I get the same error with them.

Level 2
I don't know why, but if you move the OVR::System::Init() call from OculusRenderer::initOculus() to main(), above the instantiation of OculusRenderer, it runs without errors.


Level 2
Hmm unfortunately that doesn't work for me, no matter where I put OVR::System::Init() I still get the error.

Level 3
Check for system changes, added libraries etc. If you say the old version worked fine, but now doesn't, it may be a problem with your computer. If Veelo got it to work, it may just be a conflicting library on your computer??? Can you remember changing anything? (goodluck fixing it)

And I may be wrong, but check for multiple definitions of things etc, double initializations, all that sort of stuff. And make sure your namespaces are all right!
Liam DM Software Engineer
LiamDM@SHELL ~ $ sudo apt-get install GoodCodingPractice 
 ERROR: This package is not compatible with your system