cancel
Showing results for 
Search instead for 
Did you mean: 

Build Won't Load

PeytonCrafty1
Level 3

So I'm trying to test out my Unity stuff with my Quest (I just started) and all I had was a flat plane as a test. However, when I press the Build and Run button, it builds it and runs it on my Quest, but I get stuck on a rapidly flashing Unity logo with tons of errors. Any help would be appreciated! And I did install the required components for it, I followed a guide.

3 REPLIES 3

DarkTable
Level 5

The XR stuff in Unity changes so frequently that there's a good chance the guide was out of date unless it was directly from the Oculus site. (Even some of the learning stuff on Unity's site is out of date, especially when it comes to build XR apps for Quest.)

 

I would install the Oculus Integration and get the "CustomHands" sample running in the Editor (either via link cable or AirLink if you've got the latest firmware). That will prove that all the XR management stuff is installed and all the correct boxes are checked. Then I'd try to get that scene running on device. (I use the "Oculus -> OVR Build -> OVR Build APK and Run" menu option that comes with the Oculus Integration.) That way you can be sure it isn't something about your scene that's the problem. Then you can go back to your scene and figure out what the difference is.

Unfortunately I can't do Oculus Link due to my computer not being powerful enough, but I will try to update the stuff and I'll let you know how it works.

PeytonCrafty1
Level 3

Okay so I went back through the tutorial I used and it turns out that not only did I have to update one of the plugins, I also missed the step where I had to change the compression method. I fixed it and it worked perfectly, but thank you anyways! Have a good day!