cancel
Showing results for 
Search instead for 
Did you mean: 

Editor Play, Game = black screen

Infinite
Level 2
Does anyone know what the cause for the Play and black screen issue is?

This has been reported on the forum here for over a month now, with numerous SDK upgrades and fixes. Yet this problem still persists. Sometimes it can be hard to test scenes and tweak screen space effects by having to build each time, as we have no real-time DK2 feedback to test with.
_________________________________________________ I N F I N I T E www.ir-ltd.net
33 REPLIES 33

gwzn
Level 2
Just chiming in, I would really like to see someone with some knowledge address this.

sfbaystudios
Level 2
Me too.

Gerald
Level 4
"Infinite" wrote:
Does anyone know what the cause for the Play and black screen issue is?

This has been reported on the forum here for over a month now, with numerous SDK upgrades and fixes. Yet this problem still persists. Sometimes it can be hard to test scenes and tweak screen space effects by having to build each time, as we have no real-time DK2 feedback to test with.


For me the behavior changes at random. Sometimes I get no picture (not even black), sometimes I see it as it should be and then at other times my editor window shows it instead of the Game window and in some cases it just makes the editor window flicker like crazy.
Sometimes a Unity reboot solves it, sometimes I just ignore it and a play later suddenly switches to a more normal behavior. It's all pretty weird, but I guess it is connected with me using 2 screens and sometimes moving the game window from one screen to the other.
check out my Mobile VR Jam 2015 title Guns N' Dragons

ryahata
Level 2
If I'm not mistaken there was a post about this behavior. And, if I remember correctly, it is because of a bug in the Oculus plugin. If that is the case, I assume in the editor the DLL is not using the correct swapchain. Try open multiple game views (i.e. have a popped out window and one docked) and see what happens.

All that aside, when you make a build your game works as expected, correct? If not then maybe there's a bigger issue here.

cybereality
Level 16
Can you guys post more information about your systems?

OS and video card and video driver would be a good start. Also Unity version. Thanks.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

owenwp
Level 5
Happens to me with Unity 4.5.2, win 7 gtx770 latest driver. Also sometimes the game output works, but it gets rendered into the inspector tab instead of the game tab.

Gerald
Level 4
Win 7 Ultimate 64
GTX 670 with 340.52
Unity 4.5.2f1
SDK 0.4.2

dual monitor (2x 1680x1050, 60Hz)
check out my Mobile VR Jam 2015 title Guns N' Dragons

Infinite
Level 2
Win 7 Ultimate 64
GTX 680 with 340.52
Unity 4.5.3f3
SDK 0.4.1
dual monitor (2x 1920x1080, 60Hz)
DX11

I dare not upgrade to 0.4.2 due to the horror stories of the Rift locking.

In some Unity projects with OVR, game mode works but not all the time.
_________________________________________________ I N F I N I T E www.ir-ltd.net

CubicleNinjas
Level 4
Seeing this as well.

Building on the below. Have never seen this black screen issue here:
Unity 4.5.3f3
SDK 0.4.2
OS X 10.9.3
2.3 GHz i7
8GB DDR3

The black scenes appear on:
Intel Core i7 3820 (3.60GHz)
12GB DDR3
Windows 8
NVIDIA Geforce GTX 660 1.5GB

I'm wondering if rendering type is an factor too? Using forward it seems to occur more often than deferred.