cancel
Showing results for 
Search instead for 
Did you mean: 

OVREngineConfigurationUpdater: Setting vsyncCount to 0

wakkawakkawakka
Level 3

This just started popping up today on multiple projects that otherwise run perfectly in the editor and APK builds to the headset. Does anyone know what is going on with this script or how to resolve? 

 

VREngineConfigurationUpdater: Setting vsyncCount to 0
UnityEngine.Debug:Log (object)
OVREngineConfigurationUpdater:EnforceAndroidSettings () (at Assets/Oculus/VR/Editor/OVREngineConfigurationUpdater.cs:137)
OVREngineConfigurationUpdater:OnDelayCall () (at Assets/Oculus/VR/Editor/OVREngineConfigurationUpdater.cs:88)
UnityEditor.EditorApplication:Internal_CallDelayFunctions ()

 

135 if (QualitySettings.vSyncCount != 0)
{
Debug.Log("OVREngineConfigurationUpdater: Setting vsyncCount to 0");
// We sync in the TimeWarp, so we don't want unity syncing elsewhere.
QualitySettings.vSyncCount = 0;
}
}

1 ACCEPTED SOLUTION

Accepted Solutions

wakkawakkawakka
Level 3

Actually I went back and checked and the "medium" setting was listed under the high quality setting so I clicked back on medium and you were right. I've been working on this problem for a couple hours. 

Thanks man 

 

You fixed what my eyes couldn't believe 🙂

View solution in original post

3 REPLIES 3

DarkTable
Level 6

In your Project Settings->Quality settings file you must have "VSync Count" set to something other than "Don't Sync." It looks like that script changes the value at runtime to its preferred setting.

 

dontsync.png

iIts set to Don't SyncIts set to Don't Sync

wakkawakkawakka
Level 3

Actually I went back and checked and the "medium" setting was listed under the high quality setting so I clicked back on medium and you were right. I've been working on this problem for a couple hours. 

Thanks man 

 

You fixed what my eyes couldn't believe 🙂

View solution in original post