cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Not Appearing Under "Run Device" in Build Settings

deathloser
Level 2
I'm on step 9 of trying to use Oculus in Unity development. The oculus is supposed to appear under Run Devices but its not there. Yes my device is in developer mode already. I am using a USB3 cable. I have allowed debugging and allowed the computer to access files on my Oculus. WHat should I do ?

https:// developer.oculus.com/documentation/unity/unity-enable-device/
4 REPLIES 4

deathloser
Level 2
My developer dashboard says : UNABLE TO CONNECT, this may be because of an old ADB. Terminate processes on TCP 5037 then try again

I don't know what that means

mmmzzz
Level 2
> Terminate processes on TCP 5037 then try again. I don't know what that means

If you're running linux, you can find out what is running on port 5037 with:

lsof -i:5037

Once you find out the process id (PID) using the above command, you can kill that process with:

kill 1234

assuming 1234 is the PID

Situationist
Level 2

I am having the same issue. When I connect my Quest to the app, it removes the developer toggle from the list that was there before I connected it. I am prompted to finish setup in the device, and when I got to the device, everything is set up and developer mode is already on-see vid. When I go to add an android device in my build settings, it is stuck in looking for devices mode. 

 

DId you find any solutions?

ezone
Level 4

Have you tried using the 'Oculus Developer Hub' app? You should be able to connect to your Quest via the app. You can enable 'ADB over WiFi' to rule out any USB cable issues.

Simon Edis - Ezone.com