cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Spatializer throwing errors when it hasn't been touched

CorfyCorf
Level 2

The build runs fine within the editor no issues at all. But when trying to build for the Android/PC, Mac & Linux Standalone/Universal Windows Platform unity throws about 30 errors at me all belonging to a range of scripts within the Unity Audio Spatializer. I have not touched these scripts I don't even know what they are. Does anyone have a fix? The errors mention no suitable method to override and type/namespace cant be found. 

 

I've tried setting the spatializer plugin within Project Settings > Audio to OculuSpatializer
I've tried the 'Build audio geometry for current scene' and 'Rebuild audio geometry for all scenes'

1 REPLY 1

DarkTable
Level 5

The spatializer in Oculus Integration 27 is broken for Quest/Android if you use the ONSPPropagationGeometry script on static geometry. I posted a workaround on this forum yesterday, but don't recommend using it unless you're confident modifying Oculus provided scripts.

 

You can remove all the ONSP Propagation Geometry scripts from the scene and the spatializer should go back to using the older "shoebox" spatializer. Better than silence?