cancel
Showing results for 
Search instead for 
Did you mean: 

Play Not Working in Unity with XR Toolkit and Link

davedev
Level 3
When I select "Play" in Unity editor, I do not see the VR playing in my headset. Link is working and my desktop fully connects to the headset. For example, I can build to the headset. I am using XR Toolkit. I have link enabled and when I hit play I can see the game window in the virtual desktop in link, but do not see the entire VR immersively.
6 REPLIES 6

davedev
Level 3
Figured this out. I needed to go to Project Settings->XR Plugin Management->Plugin Providers and add "Oculus Loader". This was missing in the tutorials I found and the files I downloaded. I am now able to view in my Quest with Link by hitting play in Unity and the controllers are fully working!

davedev
Level 3
Oh. I did it under the desktop tab but that might carry to the Android tab too.

jerrett_farmer
Level 2
Wow, I am in your debt. The things I have tried over the last few days. How did you figure it out?

veronikabojic
Level 2

davedev said:

When I select "Play" in Unity editor, I do not see the VR playing in my headset. Link is working and my desktop fully connects to the headset. For example, I can build to the headset. I am using XR Toolkit. I have link enabled and when I hit play I can see the game window in the virtual desktop in link, but do not see the entire VR immersively.


^I am having this exact same problem...but cannot find the "oculus loader" plug in provider right now...is there another way where it works?

ciarantrotman
Level 2
I was having this issue and it was fixed after I updated the XR Interaction Toolkit package in the package manager!

This^  I had Oculus checked under Android tab for building to HMD but didn't realize you had to go to desktop tab and check it off to get the VR experience in Oculus link. Thank you!