cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with moving to new position

emildraganm
Level 2

Hello,
I ve wrote first on the Unity forums and someone from Unity said that I should write here, because it's probably an integration of the plugin problem.


I have a problem with Unity 2019.4.9f1, latest Oculus integration and Oculus Quest 1 with hand-tracking. I have a room-scale exprience when the user can move physically through the room around a bed and a character. The problem is that at some point, I need the user to pe placed in a specific point in the space, facing the character. I tried setting the position to that place, moving towards an object from that position, but it never translates the user to that point, but somewhere near. I need that regardless of the physical position of the player, to jump to a specific point. I am using the OVRCameraRig and I tried also with OVRPlayerController. I tried also to parent the OVRCamera to an empty gameobject and that gameobject to translate, but the result is the same. I read on the forums that the problem is that the physical movement is not correlated with the world coordinates.
Is there a workaround for this issue?

Thank you.

0 REPLIES 0