cancel
Showing results for 
Search instead for 
Did you mean: 

Rift in standby (isUserPresent=false) produces much more CPU/GPU load than active app

vOwl
Level 3
Dear Pro-Developer,

we're developing an Rift VR-App using Unity 2017.3.1 and discovered an issue when Rift is not mounted (not in use).
The normal (Rift mounted) CPU/GPU (GTX1070) is 10/8%. The Standby-Load (Rift UNmounted) pushes the CPU/GPU load to 38/40% () !
We discovered that the reason for that is, that unity is rendering (~90fps) in normal mode, but ~1000fps in standby mode which causes the high CPU/GPU load.

We tried to fix that behaviour with "Application.targetFrameRate" but this won't work if VR is active in unity :-((
The issue happens with Oculus Integration AND native Unity with different unity versions 2017.2.* 2017.3.*.

Any idea how to fix that? (The system is running for several ours and is in standby 70% of the time)

Thanks in advance and best regards
Mario
3 REPLIES 3

vOwl
Level 3
There is an other unity camera active, that renders a UI-Canvas to the display (non-rift) to show a idle-screen with a message. ("come over an put on this awesome RIFT! :)")
May that be the reason?

@imperativity

Shane
Level 2
Hey @vOwl , Did you get this working correctly? Is the only option to not show the gui at all?

Shane
Level 2
Got it sorted, for me anyways. I had put vSync off in the project settings. Turned it on, and don't have mad gpu usage. Using unity 2018.3.11. Basically have a gui touch screen with controls for the experience. When the headset is on, the usage is normal enough (30% gtx 2070), but when the headset was off it was pushing 75% constantly. Have vsync turned on now and the machine is at 5% when the headset is off.