cancel
Showing results for 
Search instead for 
Did you mean: 

ghost shadows and incorrect FPS/vsync

bdeschryver
Level 2
Hey guys,

I did some tests of various parameters for my Unity build, but I don't get good results (60FPS and ghost shadows).
Here is a description of my settings and system, and the observed results:

Rift set in extended mode, laptop set primary screen (60FPS), Nvidia panel Vsync ON, Optimus disabled
Unity build in DX11, x86_64 and parameters as described in Oculus guide (Unity Vsync off)
Launching the direct_to_rift.exe
--> I get a 60 FPS demo with quite a lot of screen flickering and ghost shadows when I move my head around + jutter.
--> if Nvidia Vsync is off, I get 90 FPS and similar effects.

Do you know what I should change in my setup and config ? Why am I getting 60FPS or 90FPS and not 75?
Never managed to get this demo in Rift direct mode to work !
--> Drash, if you're reading this post and maybe if the recipe of Titans of Space is not a secret, can you describe the settings used for your build ? It works on my system in direct Rift mode... (with not perfect performance).

Thanks
8 REPLIES 8

ryahata
Level 2
When your Rift is set in extended mode you will only get 60 FPS because it appears at a regular monitor. Try putting it in direct to Rift mode and running the direct to rift executable.

Also what Unity are you building with? I think there is judder issues when your Rift isn't primary with Unity 4.5.3. I don't think you need to disable VSync at the Unity level. Especially if you are going to be using direct to Rift mode and DX11.

Just FYI the project I'm working on gets 75 FPS (most of the time) and I'm using DX11, x86_64, and direct to Rift mode.

bdeschryver
Level 2
Hello Ryahata,

I am using Unity 4.5.2f3 and SDK 0.4.2 and I can't get direct mode to work.
Any ideas ? I think you are using Unity 4.5.3 and SDK 0.4.1 right ?

I am not sure about what you say for the 60FPS in extended mode. The rift refresh rate is 75Hz so it should be the same in extended mode non ? My main laptop screen is 60FPS so I think it has to do something with that, no ?

Anyone else can post his Unity and SDK versions if able to build and execute in Direct mode ?

ryahata
Level 2
I am using Unity 4.5.2f3 and SDK 0.4.2 and I can't get direct mode to work.
Any ideas ? I think you are using Unity 4.5.3 and SDK 0.4.1 right ?

I am using Unity 4.5.3 and SDK 0.4.1. As for direct to HMD mode, I had to do a little song and dance to get that to work for me. First make sure you have all the right software installed and the firmware up to date. Then, switch it to direct to HMD mode and restart the tracking service. Next, try and run the Unity Tuscany demo. Those steps worked for me.
I am not sure about what you say for the 60FPS in extended mode. The rift refresh rate is 75Hz so it should be the same in extended mode non ? My main laptop screen is 60FPS so I think it has to do something with that, no ?

Sorry about that. My explanation was unclear. In extended mode your computer treats the Rift as a monitor and thus uses your graphics card as the display driver. I think there are some issues with VSync and running multiple displays of varying refresh rates (especially if the refresh rates are not "clear" multiples of each other [i.e. 60Hz monitor can run VSync games at 30 FPS or 60 FPS]). I don't recommend this, but you could overdrive your laptop display to 75 Hz if you want to get 75 FPS out of your DK 2 when in extended mode. I would check other forums to see if this is an "ok" option.

Hope this helps.

bdeschryver
Level 2
I managed to create a custom resolution for my main laptop display and made it 75Hz.
Now when I set Vsync ON in Nvidia control panel and use extended mode, the demo is 75FPS. nice !
BUT : I still have those ghost images when rotating my head !
Here what I have: when I look straight without moving, the image is ok. When i rotate my head quickly, I see a faded ghost image "further" than the main image in the direction of head movement, and quickly the main image gets to that point and both fade (=are superposed).
It looks to me like a prediction issue no ? If I move my head slowly, I don't see that (probably because the gap between ghost and main image is too small).
Any idea what it is ? I tried with timewarp off but that does not change. Maybe another parameter ?

I wanted to see what I have in direct mode, but I never managed to get direct mode working with my Unity builds... (it always opens on the main laptop display).

owenwp
Level 5
The ghosts are almost certainly due to the Oculus pixel overdrive technique. It reduces pixel switching latency by "overshooting" on color changes but has some artifacts like that, and may not be optimally tuned yet.

ryahata
Level 2
"bdeschryver" wrote:
I still have those ghost images when rotating my head !

When you say "ghost images" are you referring to a black smear? If so drash has a Unity package to attempt to correct for this (https://developer.oculusvr.com/forums/viewtopic.php?f=17&t=12621).

bdeschryver
Level 2
Hey guys,

I tried Drash's black smear correction and it does not solve my issue. I still see a black ghost image of the scene shifted in the direction of head rotation when I rotate my head.
I'll try to see what that gives with prediction off.
This only happens for a personal demo I made with Unity 3.5.2. Maybe with other versions it will be solved ? I am waiting for Oculus to announce compatibility with 3.5.3 or 3.5.4...

bdeschryver
Level 2
Hey !


I am still having my problem and as I was doing a simulation video of my problem (too hard to record on the rift itself), I though I would post it on the forums in case someone has the same issue.

http://youtu.be/jV1T7JqDRn4


The effect is really happening when moving my head quickly in a direction: I then have this shadow in the direction of move which disappears when I stop moving...

Any ideas ? My best guess is a hardware problem on the Rift screen as this effects occurs on different PCs/mac, no matter the software settings !