cancel
Showing results for 
Search instead for 
Did you mean: 

[v13-15] Editor crashes on play after upgrading Oculus Integration.

torano
Level 4
I just updated Oculus Integration to v13 and found Unity editor crashes with hand tracking.

What I did is make a new project and a new scene, add setup some necessary stuff such as importing Oculus Integration, and add OVRCameraRig to the scene as well as OVRHandPrefab and OVRControllerPrefab as children of the hand anchors. Finally, change the platform to Android and set OVRManager's Hand Tracking Support to "Controller And Hands". Then I hit play and it crashed. I tried Unity 2019.2.9f1 and 2019.3.0f6 but both didn't work.

The HandTest scene worked successfully just once, and at that time my scene worked too. But after rebooting It didn't work again. I don't know why. Anyone knows the solution?

By the way I am using Oculus Quest and Oculus Link.
14 REPLIES 14

Chronodos
Level 2

Digibix said:

It will crash if you press play with your controllers (in desktop view, or if you can see your controllers)

Put the quest on (with link enabled)

Make sure you cannot see the controllers

Press play using your mouse

... your hands should work in unity editor



Didn't work for me. Editor simply crashes even if I remove the batteries.



JamesButlin_FVR said:

I'm having this issue also. Seems to work in the HandTest scene but strangely not on any scenes where I try to add it to the existing OVRCameraRig prefab, despite them being identical!


It doesn't even work in the HandTest scene for me. Crashes also

zoidbun
Level 2

Chronodos said:
Didn't work for me. Editor simply crashes even if I remove the batteries.


Did you try and put the quest on - as in, put it on your head? I had to wear it while clicking play for it to not crash.

Reborn409
Level 3
Same issue... Crashes all time when I click play.

chibiskuld
Level 2
Hi all,
I just wanted to report I pinpointed the actual cause for the issue.
When in link mode, it still respects the state of your controllers. Whether you have chosen hand tracking or not.
The crash occurs when you start with controllers instead of in hand mode.
One hint to tell if you are in hand tracking mode, is actually receiving the error, "Controllers are required".
If you are seeing this, then this means link mode sees you in hand mode. You can then safely start your application. You can also tell if your hands are being tracked instead of controllers by reaching out to your guardian. If you see a ring appear because of your hands, you should be good to go.
But overall, you need to ensure you have hand tracking mode on, or turn the "Auto Detect" feature on in experimental features.

I hope that helps!

torano
Level 4
I reported these issues about 2 months ago, but these, crash with controllers on and always hands available regardless of AndroidManifest, still remains with Oculus Integration v15... I don't know why Oculus devs didn't fix yet.