cancel
Showing results for 
Search instead for 
Did you mean: 

AppLab IL2CPP requirement for Quest2?

R1PFake
Level 4

Hello,
I see IL2CPP mentioned everywhere in the official documents / tutorials and I don't want to discuess IL2CPP vs C#/Mono here. I simply want to ask if IL2CPP is an actual requirement and if my app will be rejected in AppLab if I don't use it, even it my app works and runs well?

I don't want to go into details, but I have some features that simply don't work with the current IL2CPP unless I refactor a lot of code, but I wanted to ask here so I don't waste time with further development if it will be rejected in the end.

1 REPLY 1

weiyinfu
Level 2

https://developer.oculus.com/documentation/unity/unity-conf-settings/

 

1. The app store require the app is 64bit.

2. If you want to use 64bit in unity, you have to use il2cpp

weiyinfu_0-1655106002235.png