cancel
Showing results for 
Search instead for 
Did you mean: 

Blank screen when building Unity scenes on my mac

VRex
Level 4
Hey guys,

When I try to build my Unity scene after adding either the OVRPlayerController or the OVRCameraController, it runs and then just ends on a black screen. No idea what's going on here. Anyone know what this is yet? Possibly mac support is just very weak at this point? Here are my specs:

Macbook Pro
Processor: 2.5 GHz Intel Core i7
Memory: 8 GB 1333 MHz DDR3
Graphics: Intel HD Graphics 3000 512 MB
OS: OSX 10.9.4 (Mavericks)

Any help or insight would be greatly appreciated. Thank you!
9 REPLIES 9

CubicleNinjas
Level 4
Hey VRex –

You may find this thread helpful.

I might try unchecking 'Use Direct3d 11' under Player Settings. When this is checked build receive a black screen on PCs. When unchecked they display normally.

VRex
Level 4
Thanks for the reply, CubicleNinjas. Unfortunately, Use Direct3D 11 was already unchecked. Any other ideas?

cybereality
Level 15
Do the Oculus demo apps (desk, Tuscany) work for you? Is it only your own app that has issues?

Can you try a brand new project with the Oculus package?

helmet275
Level 2
I get the Blank screen when trying to run Tuscany demo app on my MacBook Pro. The Demo in the configuration app worked fine.

helmet275
Level 2
My iMac seems to work fine with the Tuscany Demo. My MacBook Pro did once render on the main screen but I couldn't ever get it render on the DK2.

My MacBook Pro specs:
Retina, Mid 2012
2.7 GHz Intel Core i7
16 GB 1600 MHz DDR3
Intel HD Graphics 4000
OS X 10.9.4

My iMac specs:
27-inch, Mid 2011
16GB 1333 MHz DDR3
AMD Radeon HD 6970M 1024MB
OS X 10.9.4

vrdaveb
Oculus Staff
VRex, do you see any errors in output_log.txt? It's in the _Data folder next to your binary.

evalds
Level 2
I confirm, that all DK2 Unity applications ..._DirectToRift.exe does not work on Intel GPU based Macbook Pro Retina computers using Windows bootcamp.

Starting application results in no error files and windows error logs, but just mirrored display and black screen on DK2

Only demo scene of Oculus Rift & non-unity apps can be executed correctly on direct HMD mode. With great difficulty it is possible to execute Unity apps in desktop mode, because - DK2 display by default is discovered in 90* angle and it is not possible to duplicate display, but only extend it and rotate it. If you try to duplicate it it will have only resolutions in vertical mode available.

I have not yet tried to compile Unity based apps myself, but my project is not based on Unity, so I do not want install it yet, but I would really appreciate if Oculus would fix driver, so that it would work with latest Intel GPUs

Operating System
Windows 8.1 Pro 64-bit
CPU
Intel Core i7 4750HQ @ 2.00GHz 50 °C
Crystallwell 22nm Technology
RAM
8.00GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)
Motherboard
Apple Inc. Mac-3CBD00234E554E41 (U3E1) 29 °C
Graphics
Color LCD (1440x900@60Hz)
Intel Iris Pro Graphics 5200 (Apple Computer)
Storage
233GB APPLE SSD SM0256F (SSD) 43 °C
Optical Drives
No optical disk drives detected
Audio
Cirrus Logic CS4208 (AB 94)

dogukanerenel
Level 2
"evalds" wrote:
I confirm, that all DK2 Unity applications ..._DirectToRift.exe does not work on Intel GPU based Macbook Pro Retina computers using Windows bootcamp.


I have the same issue. Macbook pro with Retina display (bootcamp) directtorift.exe is black screen. I thinks Macbook Pro with retina display is the worst choice for Oculus and Unity now, i have couple other issues as well on mac side. We are waiting the stable plugin. Good news is, Unity will support Oculus http://blogs.unity3d.com/2014/09/20/expanded-oculus-rift-support-in-unity/

azul_demonte
Level 2
Hi I was having the same problem. What I did was first installing a new version of Unity. I install the 5.6.4. The last of 2017 was crashing so I install a previous one though newer than my old version. Then I followed this instructions: https://developer.oculus.com/documentation/avatarsdk/latest/concepts/avatars-gsg-unity-gearvr/
but avoiding the oculus integration download step ( i try it that way but it just crashes, i suppose that 5.6.4 version doesn't need it) It worked for me. Hope the info is useful. Im a beginner and I spend two days trying to figure this out. The black screen was certainly frustrating.