Showing results for 
Search instead for 
Did you mean: 

Deployment Issues: SystemUX and Oculus System Utilities keep stopping

Level 3

I work with a Quest 2.
I want to integrate a simple 360 video player app made in Unity.

When I "Build & Run" the usual way, the deployment freezes when the loading bar show " Copying APK package to device '1WM.... [Quest 2]' "

When I use the "Build" option and then install the apk with "adb install 'my_app.apk'" the installation goes smoothly. Same when I use the "Build & Run" from the Oculus Window from the "Oculus Integration" Asset.

But then when I open the Library in the Quest 2, it immediately closes and if I try to reopen it, same thing except I get a pop-up saying the "SystemUX keeps stopping". And when I try to open the Storage menu, the pop-up says the "Oculus System Utilities keeps stopping". After that I can reboot all I want it does not change a thing, the pop-ups will always come when opening the library or storage menu. Only solution is to reinitialize the Quest 2.
The app does not appear in the Oculus Link library.
It is still the same after rebooting my laptop and the quest. I logged out and in on the oculus android app, and reinitialized then paired the quest using said app at least 3 times.
I have read posts with the same kind of problem from a year ago, but the few solutions they had did not work.
This has been tried with and without the Oculus Integration asset.

Everything works fine when playing from the Unity Editor.

Can anyone give me some help or pieces of advice as where to look to solve this issue please ?

The same things happen when I sideload the APK from SideQuest.

Oculus Desktop:
Oculus Android:
Unity: 2019.4.11f1
    Oculus Integration 20.1

    Oculus XR Plugin 1.4.3
    Universal RP 7.3.1
    XR Interaction Toolkit preview-0.9.4
    XR Plugin Management 3.2.15

Wishing you a nice day,


Not applicable
Did you find a solution for this? I've had very similar issues using Unreal, it feels like something went wrong during an install and might've corrupted the storage. I even factory reset, and after the install of the same apk, it fails again. If not, i would suspect something in the metadata used for the app description in the library...

Not applicable

Any solution? Same with Unity!

Level 3

Hello, I never found any solution for this, the issue just disappeared along with new updates.