cancel
Showing results for 
Search instead for 
Did you mean: 

Error after upgrading from unity 2019.1.13f1 to 2019.2.5f1

VJ76
Level 4
I'm working on a quest vr project, and i'm using Oculus Intergration 1.38

Recently i have updated the project to the latest unity version.
But after a build i get the following error.
I tried to renew the manifest, but it didnt work.

Anyone know how to solve this?

NullReferenceException: Object reference not set to an instance of an object
UnityEditor.XR.Oculus.OculusManifest.UpdateOrCreateNameValueElementsInTag (System.Xml.XmlDocument doc, System.String parentPath, System.String tag, System.String firstName, System.String firstValue, System.String secondName, System.String secondValue, System.String thirdName, System.String thirdValue) (at Library/PackageCache/com.unity.xr.oculus.android@1.38.3/Editor/OculusBuildProcessor.cs:60)
UnityEditor.XR.Oculus.OculusManifest.OnPostGenerateGradleAndroidProject (System.String path) (at Library/PackageCache/com.unity.xr.oculus.android@1.38.3/Editor/OculusBuildProcessor.cs:130)
UnityEditor.Android.AndroidBuildPipelineInterfaces.OnGeneratePlatformProjectPostprocess (System.String path, System.Boolean strict) (at C:/buildslave/unity/build/Editor/Mono/BuildPipeline/Android/AndroidPostGenerateGradleProject.cs:39)
UnityEngine.GUIUtilityprocessEvent(Int32, IntPtr)
4 REPLIES 4

wdwright
Level 2
I'm getting the same error. 2019.2.6. Oculus Integration 1.4. Anyone have thoughts?

TardyTempest
Level 3
I was getting this, tried a variety of checking and unchecking boxes but kept happening, finally I uncheck V2 signing, and build succeeded. Hope this helps get you too.

wdwright
Level 2
That was it for me! Thanks!

Anonymous
Not applicable
It's a bug in Oculus Android package.
You can get a hint looking into the OculusBuildProcessor.cs script in the package. Cached in Library/PackageCache/com.unity.xr.oculus.android@X.XX.X\Editor
Check the line you get in the error's call stack. In your case it's OculusBuildProcessor.cs:130
It can't handle required attributes like:

<meta-data android:name="com.samsung.android.vr.application.mode" android:value="vr_only"/>
android:launchMode="singleTask"
android:resizeableActivity="false"

You can safely remove these attributes because these will be added automatically. The one that caused problems for me (no idea why) was vr_only meta-data.