cancel
Showing results for 
Search instead for 
Did you mean: 

OVROverlay don't work with Oculus Quest

Thomas_Lucine
Level 3
Hi guys,

Like the title mention, I can't find no way to make OVROverlay to work in any scene on the quest. Everything is working perfectly in editor through link.
I'm using Unity v2019.3.9f1, Oculus Utilities v1.52.0, OVRPlugin v1.52.0, SDK v1.52.0, Oculus XR Plugin 1.4.3 and Unity Integration 20.0.

At first I tried building OVROverlay sample scene (with and without "Protected Context" from XR settings) without success. While this is working in editor and don't show any error in build, I'm currently out of solutions. Can you think of anything else ?

**documentation/unity/unity-ovroverlay/**
This could come from this option that is no longer available : "For Oculus Quest: To enable support on Oculus Quest you must also render the OVROverlay layer as an External Surface and select Protected Content in Player Settings > Virtual Reality > Oculus."

OVROverlay layer as an External Surface ? What is this ?






5 REPLIES 5

StaRky_FR
Level 4
For whom it might help, the problem was actually caused by Unity settings
 
To get better performances the Scripting backend option was "IL2CPP" insteand of "Mono" and was causing an instant crash on OVR Overlay script.

This was verified using both URP and classic renderer. This issue might soon be reported to Unity as well.

gconvergen
Level 5
Try disabling the XR Plugin Management package and use legacy Player Settings > XR Settings.

mbzdmvp
Level 3
For anyone else encountering this issue: You should try changing your Target Architecture from ARMv7 to ARM64 in Project Settings > Player > Android > Other Settings

Ayfel
Level 4
Any news with this? I am using 2019.4.15f1 and getting the same. Not working at all in builds and no idea how to get it working. Oculus please?

Ayfel
Level 4
Yes this crashes in all builds with IL2CPP regardless of architecture in 2019.4.15f1. Mono no issues...