cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link crashes when Unity enters PlayMode and does not work until Unity Editor is restarted

andzq
Level 2
As described in the discussion title. More often than not does Oculus Link crash out of existence when entering Unity´s play mode. The setup is as follows. I use an official Oculus USB-C cable to connect my Oculus Quest to my Windows10 PC while using any Unity version past 2019 (prev. versions not tested) with the Unity build in XR Oculus package (not the Oculus Integration from the AssetStore).
The idea now is that when I press Play in the Unity editor I will be able to test my app in a similar way as if it was installed on the Quest directly. This worked without any issues until some recent Oculus update (can´t tell when exactly) which apparently let´s the Oculus Link app crash very often regardless of Unity Version or complexity of the scene. The Quest itself gets thrown back into the standard Quest homescreen, Unity will just be stuck on a black screen and the Oculus app will restart anew after its disappearance. That by itself is annoying enough. But the main problem is that I cannot just exit Unity play mode, reestablish the Oculus Link and enter play mode again to fix the problem. Oh no! The major time consuming part of this misbehavior is that once it crashed I need to close the Unity editor, then restart Oculus Link, then start the Unity editor again. Imagine having a semi-big project with an active collaborate service checking for changes every time Oculus Link decides to crash and forcing you to restart the editor. 
Please help. I do not know how to solve this. If someone at least knows a workaround or fix that does spare me from restarting the editor, I´d be more than happy.
3 REPLIES 3

RichardRacz
Level 3
Hello andzq, I have the same issue with my Unity+Quest+OculusLink. Have you found any solution or workaround for this? Thanks, Richard

paulcool88
Level 2
If you look in the release notes for Oculus integration 23.1, they say there's an issue with the editor freezing on some versions of Windows. They say they are working on a solution. You can find about it here https://developer.oculus.com/downloads/package/unity-integration/

BeardOrDie
Level 2

I know this is an old post, but I had this issue over the last few days. I still have Play Mode crashing using Oculus Link and Air Link. But here's what IS working: I purchased the Virtual Desktop app for Quest 2, and by default the Unity editor's play button will not trigger full screen VR, but the following forum post has instructions that worked for me with an admittedly hacky batch file to launch everything in the right order using the command line and specific command line argument(s). When I exit all programs, then use this Batch file, it will launch Virtual Desktop Streamer on my PC and wait for me to put the headset on and start the Virtual Desktop app on my Quest 2. Once the Virtual Desktop app on my Quest 2 connects to my PC, it will see the Unity editor which it has just launched. Then I can press Edit -> Play (for some reason the actual Play button still won't click) and it will enter Play Mode and correctly go fullscreen VR with spatialized audio, controllers, etc. I'm also using VRIF as the author of the post is, but I don't think that's related to why this is working. Best part of this is that it's completely wireless, no Link cable needed, and more performant than out-of-the-box Air Link in my experience. Here's the post URL: https://forum.unity.com/posts/6792485/

 

Of course, I hope that upcoming software updates will refine and stabilize the roundtrip workflow for Unity development, without the need for command line batch files and the third party Virtual Desktop app.