cancel
Showing results for 
Search instead for 
Did you mean: 

Possible Bug in latest Oculus Integration?

CountZeroNull
Level 2

Unity 2020.3.27f1
Oculus Integration 37.0
Oculus Desktop App 37.0.0.79.109
Windows 10
Using Link Cable

 

CPU: i7-12700k
RAM: 32GB
GPU: Geforce GTX 1080Ti

 

Create New Project
Followed all instructions on: https://developer.oculus.com/documentation/unity/unity-conf-settings/

 

Problem:
Testing any of the new Interaction Scenes through Unity Play mode create severe "ghost trail" artifacts. Building and deploying the APK to the device works fine.

 

There appears to be an issue with the scenes themselves, possibly a shader or light issue? The settings I'm using are:

 

Rendering: None

Pixel Light Count: 1

Texture Quality: Full Res

Anisotropic Textures: Per Texture

Anti-Aliasing: 4x Multi Sampling

Soft Particles: Unchecked

Realtime Reflection Probes: Checked

Billboards Face Camera Position: Checked

 

1 ACCEPTED SOLUTION

Accepted Solutions

CountZeroNull
Level 2

I resolved the issue by going to Project Settings > XR Plugin Management > Oculus, selecting the PC tab, and settings Stereo Rendering Mode to Multi Pass. Apparently Single Pass has issues now. 

View solution in original post

1 REPLY 1

CountZeroNull
Level 2

I resolved the issue by going to Project Settings > XR Plugin Management > Oculus, selecting the PC tab, and settings Stereo Rendering Mode to Multi Pass. Apparently Single Pass has issues now.