cancel
Showing results for 
Search instead for 
Did you mean: 

Prebuilt DK2 Tuscany demo is 75fps. 60fps when I build it.

pukeanddie
Level 2
I am trying to figure out why all the oculus projects I am building max out at 60fps. I'm able to run the prebuilt unity tuscany demo and it's nice and smooth at 75fps. If I create my own unity project, import the tuscany demo package and then update the settings suggested in the documentation, I'm still only able to achieve 60fps. I'm wondering if I am doing something wrong?

Has anyone else seen this issue? I'm running on a mac pro trashcan running windows 8.1
9 REPLIES 9

Anonymous
Not applicable
You can change the Vsync settings in unity to match with the oculus in Quality settings:

http://docs.unity3d.com/Manual/class-QualitySettings.html

You can also force a framerate with application.targetframerate:

http://docs.unity3d.com/ScriptReference/Application-targetFrameRate.html

pukeanddie
Level 2
Thank you. I've tried all three Vsych options, and played with targetFrameRates. But unfortunately it is still playing at 60fps.

pukeanddie
Level 2
I made a breakthrough on my problem. The frame rate shot up to 75fps as soon as I set Direct To Rift mode in the config util. I had it set to extended desktop, even though I was playing it via direct to rift. However I still can not explain why the prebuilt Unity demo achieves 75 fps in either mode.

CubicleNinjas
Level 4
I'll hazard a guess...

When in extended mode the refresh rate of the main monitor is often used. If you're seeing a consistent 60fps, this is VSync working using your monitor's max settings.

To get around this you can make the Rift the primary screen. Setting it to the left seems to help too. Doing these lets the 75fps of the Rift take over.

kersk
Level 5
You are most likely seeing this because Unity 4.5.3 introduced an issue where apps are vsync'd to the primary monitor's refresh rate. Unity is working on a fix for this! In the meantime you can downgrade to Unity 4.5.2, use direct mode, or set your DK2 as the primary monitor when running VR content. (The prebuilt Tuscany demo was created with Unity 4.5.2, btw)

CubicleNinjas
Level 4
"kersk" wrote:
You are most likely seeing this because Unity 4.5.3 introduced an issue where apps are vsync'd to the primary monitor's refresh rate. Unity is working on a fix for this! In the meantime you can downgrade to Unity 4.5.2, use direct mode, or set your DK2 as the primary monitor when running VR content. (The prebuilt Tuscany demo was created with Unity 4.5.2, btw)


Thank you for the explanation here! That is super helpful and so excited to hear this fix is on the way within Unity.

Ondrejicek
Level 2
I had the same problem today when I built Tuscany with Unity 4.5.5 Free + the new Unity Integration package. With the current runtime (0.4.3 Beta) I was getting constant judder and could not get over 60 FPS (only if I disconnected my monitor which is not useful). I have Windows 7 64 bit and GeForce GTX 670. The official build was running fine though. First I tried disabling Aero. It helped, but I got some minor tearing on right side of the display.
The final solution for me was building the game with vsync enabled + running with -force-d3d9.

vrdaveb
Oculus Staff
If you build your app with DX11, it will only run at 75fps in direct display mode, which your users will need to set through the oculus configuration utility. You can build with DX9 instead by going to Edit > Project Settings > Player > Other Settings and un-checking "Use Direct3D 11".

BradleyNewman
Level 3
I set all the same settings as indicated in the docs but still had tearing in the right eye and seemed like it was maybe 60 Hz. I enabled DX11 and the tearing went away and the frame rate looks like 75 Hz.

Unity 4.3.4f1
nVidia Geforce GTX 770
Win7 64 bit