cancel
Showing results for 
Search instead for 
Did you mean: 

Quest Only Renders Right Eye

Context: I recently upgraded to Unity (2020.3.30f1). I am using Oculus XR Plugin (1.11.2) and XR Plugin Management (4.2.1). I am using OpenGLES3 Graphics API, Multi Pass Stereo Rendering Mode, using the Default Render Pipeline.

 

Issue: My build appears to render the right eye correctly. However, the left eye appears to show a single color sampled from somewhere on the display. As I turn my head I can see various colors from the scene in my left eye. It's as if my left eye were magnified down onto a single pixel. 

 

This issue even occurs during Unity's initial loading splash screen, before the scene's OVR Camera is even enabled. It also occurs in my custom made splash scene before the main scene loads. If I walk to the edge of my chaperone guardian I can see the boundaries with both eyes. If I open the Oculus menu I see it with both eyes.

 

No errors in the editor. No errors in the build. I've removed Post Processing V2 from my Plugin Manager and anything dependent on it. I have tried changing to Multiview (Single Pass) stereo rendering, but then nothing renders in either eye. I have also tried enabling "Use Per Eye Cameras". No dice. 

 

I noticed this was not an issue when I switched to using OpenXR. However OpenXR does not support hand tracking to my knowledge, which it a critical necessity for my project.

 

If anyone has had issues similar to this I'm open to suggestions.

9 REPLIES 9

Okay, bumping for posterity. I reverted to the 2019.4.11f1 backup version of the project and upgraded again to 2020.3.30f1. This time I just resolved the editor errors and built out an APK, without any edits to the VR backend -- same issue. I'll open a support ticket at my convenience, but my next action item is to move to Unity 2021.2.13f1 to see if this issue is resolved. Cheers.

This issue continues to occur in Unity 2021.2.13f1. I have built out the project with 2021 OpenGLES3 and Vulkan APIs yielding the same result. OpenXR renders properly to both eyes, but I have no input system and OpenXR excludes the Oculus Plugin-in Providers necessary for my project.

I've returned the project to Unity 2019.4.11f1 and the issue remains absent.

 

Edit: I've moved up to 2019.4.22f1 with the same issue-absent results.

j7-Hitstream
Level 4

I've got the same problem Unity 2020.3.3f1 - all works fine. 

If I update Unity 2020.3.29f - only the Right eye renders, left is just a blank / grey / single colour.

I think it's because when using 2020.3.3f1 

XR Plugin Management module is V4.0.7 - it wont go above this version

Oculus XR Plugin 1.8.1 - it wont update beyond this version.

 

When i update to Unity 20.3.29f

XR Plugin Management model is 4.2.0 - cant get to previous version

Oculus XR Plugin is 1.11.2 - again cant get to previous version

 

Anyone got any other ideas to fix?

LezginT
Level 2

I ported my quest project from 2019.4.12f to 2019.4.38.

and "played around" with the packages.

 

In my project it seems like the same problem is occuring when updating the Oculus XR Plugin.

In the project Oculus XR Plugin 1.5.1 is installed. Changing anything with it leading to the render issue mentioned by jordan.

 

I also tried deleting the post process plugin. 

 

Taking this in account I tried to port the working 2019.4.38 project to 2020.3.33 but it seems like all plugins get auto-updated, so of cause the same render issue appears with Oculus XR Plugin 1.12.0

Thanks for confirming, it would be good to understand if anyone has managed to fix this problem.

Cain_Bloodbane
Level 5

This one took me hours to figure out how to get working, and I am pretty sure this is what had me stop working on my VR project several months ago when I was last working on it because updating would cause this to happen.

I used GIT to help so I could undo changes I had done. The newest release had to work I knew, because how else would it have become a non-preview package?

One of the problems seems to be the Oculus Integration asset from the store, it needs to be updated. A new version 40 was released a few days ago. Doing that seemed to help, because now at least I could see the Unity splash screen with both eyes, but inside the app it was not the right eye that was black.

Then I disabled the Oculus OVRPlugin by going into the Oculus menu, which should be between the Tools and Window dropdown if the integrations asset is installed.
Select Oculus -> Tools -> OVR Utilities Plugin -> Set OVRPlugin to Package Manager-provided (Disable OVR Utilities version)

Still no luck though. I also tried changing the stereo rendering method to Multiview instead of Multipass and that on its own also did not work.

I found that the last problem was a setting in the OVRManager script on the OVRCameraRig in the scene, it had the option Monoscopic enabled. That option does seem to help improve performance quite a bit, because my controllers would not render fast enough and swinging them in front of my eyes they would not be smooth moving. With the old plugins, this Monoscopic would help improve that performance, because it ensures the view is only rendered once. So I guess its like the old "single-pass rendering". But now I have that same performance with this option disabled.

So to sum up...
Update the Oculus Integration asset to version 40 and ensure the OVRCameraRig does not have Monoscopic enabled. Now its all working in Unity 2021.3.4f1 with the Oculus XR Plugin version 3.0.1 and the XR Plugin Management version 4.2.1. The step were I disabled the OVRPlugin was not necessary and I have now activated it again. If you disabled it, you will have to use the "update" step in the same menu where you disable it. Not sure what difference it makes though... might help with the new XR feature where you can use passthrough.

owaisa
Level 2

I managed to fix it as well but I don't exactly recall how. I know I had to force update the XR Plugin to 3.0 on 2021.1.16

GSU_J
Level 2

Hi there,

 

I have also lost in direction about this problem. This is the Answer.

 

"Project Settings" -> "XR Plug-in Management" -> Check "OpenXR" instead of "Oculus" at "Plug-in Providers".

And then, Set OpenXR Settings in drop menu.

Using Versions

Unity Version : 2020.3.36f1
OpenXR Package Version : 1.4.2

Oculus XR Plugin Package Version : 1.12.1